84

I am running Kubuntu Hardy Heron, with a dual monitor setup, and have VirtualBox on it running Windows XP in seamless mode.

My problem is, I can't get VirtualBox to extend to the second monitor.  How can this be achieved?

migrated from stackoverflow.com Feb 16 '10 at 10:44

This question came from our site for professional and enthusiast programmers.

  • Of course if you have the guest additions installed, you could make the window as large as you like. Obviously this won't make Virtualbox use multiple displays, but it will expand across as many monitors as your host machine supports. – willoller Sep 2 '10 at 5:10
  • @David: For your bounty to be useful, better explain what is missing in the accepted answer. – harrymc Jun 19 '13 at 5:38
  • @harrymc the step in the accepted answer that says perform the standard "Extend the desktop onto this display" method based on the Guest OS is vague, and it is not clear how to perform this on a Ubuntu Guest. Is there some program, driver, or specific configuration to do this? Also, there are three sections. How do they differ and in which context would I choose one over the other? – David LeBauer Jun 19 '13 at 15:06
  • "Extend the desktop onto this display" is referring to the guest OS's built-in method for managing multiple monitors. This differs between different guest OSes, of course. – jpaugh Sep 8 '17 at 19:56
104

VirtualBox 3.2.1 supports multiple guest monitors. The documentation was not clear on how to enable this.

Basic Setup

  1. Power off your virtual machine if it's on.
  2. From the main VirtualBox window, select your VM and choose “Settings”.
  3. Choose “Display”.
  4. Below “Video Memory” is “Monitor Count”. Slide it to 2, and adjust your video memory if VirtualBox complains.
  5. Start your guest and perform the standard "Extend the desktop onto this display". This will be different per guest OS. (Guest Additions need to be installed.)
  6. A second “Oracle VM VirtualBox” window will appear with the second display. You can resize it however you want.

The VirtualBox “View” menu will have an entry for each “Virtual Screen”. All but the first can also be enabled/disabled from here. This seems to only work after step 5.

Seamless/Fullscreen

  1. Enter Seamless or Fullscreen. I'll assume your HostKey is the default “RightCtrl”.
  2. If the screens are on the wrong displays, hit RightCtrl+Home.
  3. From the View Menu, choose “Virtual Display 1” and set it to the Host display you want. The other displays will shuffle around to accommodate this. If you have more than two virtual displays, repeat with “Virtual Display 2” and so on.

Headless

  1. Set the number of monitors with VBoxManage modifyvm "vm name" --monitorcount X
  2. Enable multiple vrdp connections with VBoxManage modifyvm "VM name" --vrdpmulticon on
  3. Use VBoxHeadless to launch as normal.
  4. Connect to monitor 1 with rdesktop -d \@1 ip-address-of-host and connect to monitor 2 with rdesktop -d \@2 ip-address-of-host. This is explained in lomaxx's answer. (You might be able to use @ instead of \@, depending on your shell.)
  • Silly me, messing with this for two hours before googling it. Forgot to install VM additions; thx. – tsilb Mar 29 '11 at 19:44
  • This resolved my issue of seamless mode appearing on a different monitor than full screen/normal mode. Right-ctrl/Home fixed it, allowing me to move to "Host Screen 3". Thanks for the thorough post! – Tim S. May 17 '17 at 12:41
  • 1
    Once the machine booted, on the VirtualBox menu I also had to click 'View > Virtual Screen 2 > Enable' – n00b Dec 6 '18 at 17:28
1

I am running Debian Sid and i was able to get windows 7 and xp to run in seamless in dual monitor mode, with 3D acceleration, you need to install your guest additions in safe mode.

the steps i took were:

install os with dual screens enabled already, if your o/s is already installed i am unsure if you will get support, though i would recommend following the below to do so.

after install hit F8 while booting up windows

select run in safemode with networking (networking isnt really needed, but thats the step i took)

then install guest additions 32bit (dual screens works in 64 but 3D does not) reboot and you should have dual screens available with 3D support on One monitor (:1)

i couldn't get it to work on both. I did Not have vrdp enabled to do this and it worked just fine.

1

Start your guest and perform the standard "Extend the desktop onto this display" method based on the Guest OS. (Guest Additions need to be installed.)

This one confused me. I looked all over the Guest Additions and couldn't find it. In the hopes that it might help someone else, it is talking about the Control Panel in Windows itself. In the Control Panel click on Display -> Setting and there you will see the "Extend the desktop onto this display".

1

AFAIK you can use multiple monitors only in the following instances:

  1. Multiple monitors currently work only with Windows XP guests, and Guest Additions must be installed, as the implementation resides in the Guest Additions video driver.

  2. Multiple monitors work only with the VBoxHeadless frontend. You must also enable VRDP multiconnection mode (see chapter 7.4.6, VRDP multiple connections, page 94) to access two or more VM displays when the guest is using multiple monitors.

VirtualBox User Manual
For reference, archived copy of Version 1.6.4 of the manual, from July 29, 2008

1

As long as you have guest editions installed, all I had to do was go to

Settings -> Display -> Monitor count -> Change to two (This is with the machine powered off running Windows 10). Then, once I had started the machine I went to View -> Virtual Screen 2 -> Enable

Not sure if this will work for you.

  • 2
    The accepted answer already outlines this solution – Ramhound Jan 19 at 21:54
  • the chosen one outlines it, however with too many redundant and lengthy texts, for example for me worked this one (I was about to post too) - however I had to lower the graphics memory megabytes, and switching from VMSVGA to VBoxVga, how the chosen answer addresses this. Unfortunately it does not at all. – FantomX1 Jun 22 at 16:51
0

I found that if I moved the Virtual Box VM Launcher on to the secondary monitor, and THEN pressed "Start" I was able to resize the window that appeared to fit onto my secondary monitor. If I started it from my primary monitor, I could not resize it any larger than my primary monitor.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.