5

There are many forum threads around the web about Windows 10 breaking Surround Sound / 5.1 DTS / 5.1 Dolby, etc... However there appear to be a few different possibilities, and while some noted to fix it using unlocked Realtek drivers, I have tested this myself with the following results.

BACKGROUND

See screenshots below of all of my settings screens:

enter image description here

enter image description here

enter image description here

enter image description here

Windows 10, PC connected HDMI to my Samsung TV, and digital optical out through a Realtek soundcard to my Pioneer receiver (DD and DTS capable).

PC is a SHUTTLE SH67H3 PC

I have tried Realtek's R2.79 drivers Win10 x64. I have also tried the WIN10 x64 drivers from Shuttle's site (linked above). Both don't actually show the DTS/DD output option. The unlocked R2.79 drivers DO show that option, but more info on that below.

This worked in WIN7 without any headache, and using the built in drivers WIN7 applied to the soundcard. Didn't even need the realtek drivers.

Just use HDMI to your TV, and back to the receiver you idiot

Wouldn't that be nice! HDMI goes through the Samsung TV in full 5.1 glory, but the Samsung TV will not output it back out to the receiver in the same format it got it! It sends it back to the receiver as 2 channel.

Just use HDMI switching on your receiver instead you idiot

The receiver does NOT like the samsung TV as a single output. I get resolution issues, flicker, refresh rate problems, the list goes on. It is a far bigger headache to try and get the video to work right when putting all inputs in the receiver, and I decided it was time to let the TV handle all video itself.

And again, this DID work on WIN7.

TEST

My tests are always using a test DTS 5.1 file which plays sound in each speaker one at a time when DTS 5.1 is active and working properly. I have an MKV version which is also on PLEX (which plays through a browser).

PROBLEM

The below is true for either official Realtek driver file, and the built in windows 10 drivers (before realtek was even installed).

  • Windows Movie and TV player, and Windows Media Player output NOTHING. No sound. Likely due to a codec issue though...
  • VLC, with S/PDIF pass through disabled, output is 2 channel only. It is not DTS 5.1 or DD 5.1. The test file plays sounds only in the front L/R speakers one at a time as it cycles through all 5 speakers. When it gets to LTE channel, nothing plays at all, silence.
  • VLC, using S/PDIF pass through option, works flawlessly and outputs DTS or Dolby Digital 5.1 sound through the optical output on my PC, to my receiver. Each speaker has it's own channel and the test file works flawlessly.
  • Plex, in Chrome, IE, or FF, is never outputting DTS or DD 5.1. I can confirm that it is playing "original" file and there is zero transcoding taking place. I've tried tons of plex settings, nothing seems to work. This is just like VLC with S/PDIF pass through DISABLED. I get 2 channels only and LTE doesn't work at all in the test file.
  • Websites in Chrome, IE, FF are just like the above, no change. I cannot get DD or DTS to be output.

The below is true for the unlocked realtek R2.79 driver.

  • I can go into the Realtek settings screen and now from the dropdown select DTS or DD. All of the sudden my receiver is showing DTS or DD on the front panel, SUCCESS!?!? NO.
  • In fact, it is outputting DTS/DD. But it's not treating the files right. Just like in all the tests above, I cannot hear the LTE channel in the test file in any test, and the rear/center speakers are made only accross the L/R front speakers.
  • What's worse, the S/PDIF passthrough in VLC now does the same thing, it no longer functions properly!!! So even though it says DTS, and it very well may be outputting that, it is downmixing everything it gets into 2 channels only!

So this is the problem, and I have found no solution to date. I am all ears. My goal is to get at least one browser capable of outputting 5.1 in DD or DTS in its true form. From Xfinity TV webapp, Plex, HBO Go, and Netflix at a minimum.

bumped to the homepage by Community 15 hours ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

  • Almost 2 years later, still no fix to this that I have found / been successful with... – Shackrock Jan 21 '18 at 21:38
0

I've just spend whole Sunday solving this crap! But after all those hours I have a working 5.1 audio on Windows 10 (1809) through optical S/PDIF on my ASRock X470 (Realtek ALC1220). And it's not just DTS pass through!

There are many VERY VERY LONG threads discussing this, the most useful comment was this one.

The solution:

  1. you need to download that patcher that will "fix" the missing features
  2. download proper driver, that is still compatible with the patcher - in my case I've used version 2.82, the file name is "0009-64bit_Win7_Win8_Win81_Win10_R282.exe" (this is a two years old driver!!! I've tried to use official one for my MB but the patcher didn't worked)
  3. unzip this .exe file to access the files and patch two .dll files in the "WIN64" directory
  4. install the driver - here you will get a warning from Windows that the driver is not signed!
  5. reboot and finish configuration in the "Sound" window:
    a) on the tab "Enhacements" check "Disable all sound effects"
    b) on the tab "Advanced" for "Default Format" select "Dolby Digital Live (5.1 Surround)" - FINALLY!!!

If this feels like too much, here is the fixed installer (you still need to do the step 5 and execute the patcher - it needs to modify your Registry as well).

PS: Testing video file.

NOTE: The patcher gets some false-positive detection. But it doesn't require elevated rights to be executed and it's 4 years old. So I would say it's quite safe.

-2

im using a intel NUC wich has hdmi and optical out. The only way i could get surround from the optical was disabling hdmi audio (intel audio in my case in device manager) reboot and done! Im in win10 using vlc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.