0

I just built my computer and I tried to install Xubuntu, but shortly after I start the install my monitor gives me the message out of range, and it doesn't allow me to finish installing it. I've seen a number of other posts about the same issue under slightly different circumstances or having solutions that don't work for me.

I got to the installer boot menu, and I tried both the try before installing and the install options, and both start showing 4 loading dots and Xubuntu 16.04 in plain-text. Sometimes a few lines of text show something, but soon after I get the out of range message.

I tried installing with other options like vga=771 and a few other, but they didn't seem to make much difference. The installer boot menu said to type menu in to return to that menu, but that didn't seem to do anything and it just started to install, so I'm not sure if it even took any of the options I tried. I also tried pressing some function keys as some solutions suggested, but all any of them seemed to do was refresh the installer boot menu.

I tried installing the regular Ubuntu, but it did the exact same things. I also tried installing Linux Mint, and it also gave me the out of range message. I tried installing Debian, and it had a completely different install boot set up, but I ran into an issue with it not being able to read from the cdrom, even though I'm using a usb with YUMI to install it, which also seemed to be a common issue that I couldn't find a solution to.

My computer is using a GTX 1070, and my monitor is an ASUS VN279Q. (I can provide additional system info if necessary)

What can I do to actually get Xubuntu installed? I would even settle for one of the other distros I mentioned.

  • Do you ever see a screen that says: Install Xubuntu/Try Xubuntu without installing/...? If so, it is easy, just let me know. – MariusMatutiae Jul 1 '16 at 10:54
  • Yeah the installer boot menu has those options – DeadEli Jul 1 '16 at 14:06
0

Do you have built-in video on your motherboard? If you do, I would try using that port instead just for the install, and then after you get it working attempt to install the additional NVIDIA drivers to get that graphics card working.

You may want to research your model of NVIDIA card more, I had some issues with my new laptop and in order to get my wireless NIC working I had to install a newer kernel version than what comes with debian in order to get it working. I'm not sure if more support for graphics chipsets come with new kernel versions, but it did for my intel wifi chipset.

You may also want to try vga=ask

0

This is a problem with X11 and the frequency refresh rate being (probably) larger than your monitor allows.

Since you are trying to install Linux for the first time, what you should do is to set the nomodeset option for the installer; you can find this option under the Other options on the screen where you are offered to choose between Install Xubuntu or Try Xubuntu without installing. Then you can proceed with the installation.

After the installation X11 is perfectly capable of configuring itself, which means it is not likely you will experience further problems. But even if you do, we can then use standard Linux commands to circumvent the problem. But we'll cross that bridge when we get there.

  • I have a different menu than the pictures I see online. I don't have other options to be able to select nomodeset. I found that I could press tab and see some terminal command with a lot of options. One thing I saw said to replace splash with nomodeset and it started load things differently, but it still gave me the out of range message eventually. – DeadEli Jul 1 '16 at 21:39
0

There is a compiled driver that already supports GTX 1070, which is 367.

I didn't know about the nomodeset command,so what I did is just use my integrated graphics to boot up into Ubuntu and install the latest driver that supports GTX 1070 (which is 367) from the graphics-driver PPA. Do not install the latest driver from the Nvidia's website because it won't install the 32 bit drivers and causes some application fails to start, such as Steam.

After you booted up into Ubuntu using your integrated graphics or using the nomodeset, install the drivers from PPA.

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-367

and after that reboot your machine, now you can start using your GTX 1070/1080. You can see my full write up here https://www.abiraf.com/blog/installing-nvidias-proprietary-gtx-1070-and-1080-driver-in-ubuntu-1604-how-to-get-around-the-out-of-range-error-and-a-guide-to-do-a-realtime-monitoring-of-your-gpu

  • How do you "boot up into Ubuntu ... using the nomodeset"? – Fund Monica's Lawsuit Sep 14 '16 at 3:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.