6

I did run my overnight computations and when I came to my computer, it is restarted :-( I am not sure why, but it is quite possible that it could have been automatic restart due to updates.

How do I stop Windows 10 from automatic restarts?

I have found this setting:

enter image description here

and I did apply it now, but is it enough to block all automatic restarts, even when I am not present at the computer and cannot react to the notification? In the past I noticed that some similar notifications had a countdown timer and if you didn't react, it restarted the computer (quite stupid, but that's how it SW nowadays...).

6

1 Answer 1

1

Yes, this is enough to stop the computer from automatically restarting, after installing updates you will be prompted to manually schedule a restart.

7
  • so aren't there any countdown timers in the notification prompt?
    – Tomas
    Jul 2, 2016 at 9:44
  • As far as I know, no.
    – Kodikuu
    Jul 2, 2016 at 9:44
  • 2
    If you set Windows to notify you available updates, it works exactly like previous versions of Windows, Windows 10 simply requires you to install them when prompted. Windows 10 Home also requires you to run the current build, and does not let you defer that upgrade, that option is limited to Windows 10 Professional,
    – Ramhound
    Jul 2, 2016 at 9:47
  • @Ramhound I am confused now. Could you please post a full answer to my question and whether or not this setting is sufficient and won't reboot automatically?
    – Tomas
    Jul 2, 2016 at 18:20
  • 2
    @Tomas setting notify to schedule a restart is not all you need to do. you can keep deferring updates to a future time, but eventually you won't be able to anymore and windows will force a restart, especially if it's a security update.
    – the beest
    Sep 2, 2016 at 17:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.