1

I have 2TB Wester Digital external hard drive. I connected it to USB 3.0 port on my laptop with Ubuntu 14.04 (64 bit) installed. It was working fine till yesterday (Haven't tried on any other OS). While moving some files, It freezed my OS and I have to hard reboot my laptop. Since then, nautilus is not showing the hard drive.
I tried several solutions provided on SU as well as other forums with no avail. However, it once got detected via 2.0 port but almost all directories were empty but the expected space is still occupied. I rebooted then in windows to run chkdsck but My computer didn't display it. Although Disk manager shows it but it says "Disk needs to be initialized.". If I tried to do the same, it exits with "I/O device error" message. I rebooted again in Ubuntu and again I am not able to see it. dmesg also says something about I/O error and enclosure error. Disk as well as cable are in excellent condition (I bought it only 12 days ago).
It still shows in lsusb and disks but not in gparted and fdisk -l, they displays the internal hard drive only.
Please help as the disk contains crucial data which I can't afford to lose.
Here are the logs of lsusb, dmesg and fdisk -l.

lsusb :

Bus 002 Device 006: ID 13ba:0018 PCPlay Barcode PCP-BCG4209
Bus 002 Device 005: ID 046d:c05a Logitech, Inc. M90/M100 Optical Mouse
Bus 002 Device 003: ID 0a05:7211 Unknown Manufacturer hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 1058:259f Western Digital Technologies, Inc. 
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 12d1:1506 Huawei Technologies Co., Ltd. E398 LTE/UMTS/GSM Modem/Networkcard
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 0c45:6483 Microdia 
Bus 001 Device 003: ID 8086:0189 Intel Corp. 
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

dmesg :

[ 2699.002513] usb 4-1: new SuperSpeed USB device number 2 using xhci_hcd
[ 2699.019491] usb 4-1: Parent hub missing LPM exit latency info.  Power management will be impacted.
[ 2699.021995] usb 4-1: New USB device found, idVendor=1058, idProduct=259f
[ 2699.022006] usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2699.022012] usb 4-1: Product: My Passport 259F
[ 2699.022017] usb 4-1: Manufacturer: Western Digital
[ 2699.022022] usb 4-1: SerialNumber: 575851314143354A30505645
[ 2699.023068] usb-storage 4-1:1.0: USB Mass Storage device detected
[ 2699.024255] scsi11 : usb-storage 4-1:1.0
[ 2700.023050] scsi 11:0:0:0: Direct-Access     WD       My Passport 259F 1004 PQ: 0 ANSI: 6
[ 2700.023314] scsi 11:0:0:1: Enclosure         WD       SES Device       1004 PQ: 0 ANSI: 6
[ 2700.023836] sd 11:0:0:0: Attached scsi generic sg4 type 0
[ 2700.024129] scsi 11:0:0:1: Attached scsi generic sg5 type 13
[ 2700.025888] sd 11:0:0:0: [sdc] Spinning up disk...
[ 2708.055931] scsi 11:0:0:1: Failed to get diagnostic page 0x8000002
[ 2708.055952] scsi 11:0:0:1: Failed to bind enclosure -19
[ 2708.055980] ses 11:0:0:1: Attached Enclosure device
[ 2753.841802] usb 4-1: reset SuperSpeed USB device number 2 using xhci_hcd
[ 2753.858136] usb 4-1: Parent hub missing LPM exit latency info.  Power management will be impacted.
[ 2753.858975] xhci_hcd 0000:0b:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff88012832b400
[ 2753.858987] xhci_hcd 0000:0b:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff88012832b440
[ 2763.975730] usb 4-1: reset SuperSpeed USB device number 2 using xhci_hcd
[ 2763.992107] usb 4-1: Parent hub missing LPM exit latency info.  Power management will be impacted.
[ 2763.993072] xhci_hcd 0000:0b:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff88012832b400
[ 2763.993084] xhci_hcd 0000:0b:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff88012832b440
[ 2780.116596] usb 4-1: reset SuperSpeed USB device number 2 using xhci_hcd
[ 2780.132879] usb 4-1: Parent hub missing LPM exit latency info.  Power management will be impacted.
[ 2780.133680] xhci_hcd 0000:0b:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff88012832b400
[ 2780.133686] xhci_hcd 0000:0b:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff88012832b440
[ 2780.244859] usb 4-1: reset SuperSpeed USB device number 2 using xhci_hcd
[ 2780.260832] usb 4-1: Parent hub missing LPM exit latency info.  Power management will be impacted.
[ 2780.261710] xhci_hcd 0000:0b:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff88012832b400
[ 2780.261720] xhci_hcd 0000:0b:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff88012832b440
[ 2790.378448] usb 4-1: reset SuperSpeed USB device number 2 using xhci_hcd
[ 2790.394390] usb 4-1: Parent hub missing LPM exit latency info.  Power management will be impacted.
[ 2790.395224] xhci_hcd 0000:0b:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff88012832b400
[ 2790.395234] xhci_hcd 0000:0b:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff88012832b440
[ 2790.396013] sd 11:0:0:0: Device offlined - not ready after error recovery
[ 2701.030924] ................ready
[ 2790.396164] sd 11:0:0:0: rejecting I/O to offline device
[ 2790.396193] sd 11:0:0:0: rejecting I/O to offline device
[ 2790.396205] sd 11:0:0:0: rejecting I/O to offline device
[ 2790.396214] sd 11:0:0:0: [sdc] READ CAPACITY failed
[ 2790.396219] sd 11:0:0:0: [sdc]  
[ 2790.396223] Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK
[ 2790.396228] sd 11:0:0:0: [sdc] Sense not available.
[ 2790.396237] sd 11:0:0:0: rejecting I/O to offline device
[ 2790.396246] sd 11:0:0:0: [sdc] Write Protect is off
[ 2790.396252] sd 11:0:0:0: [sdc] Mode Sense: 00 00 00 00
[ 2790.396261] sd 11:0:0:0: rejecting I/O to offline device
[ 2790.396269] sd 11:0:0:0: [sdc] Asking for cache data failed
[ 2790.396273] sd 11:0:0:0: [sdc] Assuming drive cache: write through
[ 2790.396527] sd 11:0:0:0: [sdc] Attached SCSI disk

fdisk -l :

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x0c7a859b

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          206848   136521727    68157440    7  HPFS/NTFS/exFAT
/dev/sda3       136523774   976768064   420122145+   f  W95 Ext'd (LBA)
Partition 3 does not start on physical sector boundary.
/dev/sda5       216027136   469608447   126790656    7  HPFS/NTFS/exFAT
/dev/sda6       469610496   723189759   126789632    7  HPFS/NTFS/exFAT
/dev/sda7       723189823   976768064   126789121    7  HPFS/NTFS/exFAT
Partition 7 does not start on physical sector boundary.
/dev/sda8       136523776   207828463    35652344   83  Linux
/dev/sda9       207831040   216025087     4097024   82  Linux swap / Solaris

Partition table entries are not in disk order

If it helps, VLC Player also gave I/O error in past while playing some files directly from the external hard disk.
Any help is really appreciated.

1
  • This is most likely a hardware issue with the external drive itself, it's probably defective - I'd take it back to the store.
    – JonasCz
    Jul 3, 2016 at 18:09

1 Answer 1

0

What's the drive's exact model? Do you hear any abnormal sounds? I'd try the drive on a Windows system and see if it's detected in the BIOS, Device Manager or Disk Management and how (screenshots would be useful).

I'd also try running WD Data Lifeguard Diagnostic tool and see if it recognizes the drive. If it does I'd see if the drive passes both the quick and the extended tests.

Did you try the drive on other systems?

Captain_WD.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.