0

I have a XAMPP running on Windows on port 8012. I can access it the laptop itself. When I enter my laptop's IP 192.168.1.101:8012 in my phone's browser, I am getting ERR_CONNECTION_TIMED_OUT. I am using a router, so the phone and the laptop are in the same network. My phone's IP is 192.168.1.104. Also I have opened port 8012 in my Windows Firewall. When I turned off the firewall, it worked - the phone gets the page. But when I turn it on here is part of the firewall log:

2016-07-03 19:03:38 DROP TCP 192.168.1.104 192.168.1.101 49077 8012 60 S 1385359635 0 29200 - - - RECEIVE
2016-07-03 19:03:38 DROP TCP 192.168.1.104 192.168.1.101 49078 8012 60 S 1688611369 0 29200 - - - RECEIVE

Any ideas why?

  • What is your phone's IP address? How is it connected to your network? – DavidPostill Jul 3 '16 at 11:01
  • Updated info in question. – CuriousGuy Jul 3 '16 at 11:06
  • I assume you can open the page from the computer itself by using 192.168.1.101:8012. What happens if you disable the firewall on your computer? – Zina Jul 3 '16 at 15:54
  • @Zina please see the updated question – CuriousGuy Jul 3 '16 at 16:08
  • As it works when you disable the firewall that means that the firewall rule you have created is faulty. You should correct the firewall rule. Enable it in all profiles. Can you share a screenshot of it? – Zina Jul 11 '16 at 6:01
0

Check in the windows firewall -> inbound rules -> file and printer sharing ( echo request - icmpv4-in)

it should be set on enable

  • what does printer sharing have to do with apache? – CuriousGuy Jul 3 '16 at 16:26
  • it's the echo request. have you tried pinging the pc from your phone? it should be this case – Ozeta Jul 3 '16 at 16:27
  • I can ping my phone through my laptop. Firewall is dropping packets which I've allowed to accept. Why is that? – CuriousGuy Jul 3 '16 at 16:34
  • you have to check the reverse. can you ping your pc from your phone? if not, try my solution – Ozeta Jul 3 '16 at 17:17
  • I haven't tried the ping, but I changed the file and printer sharing to enabled. Still can't get the webpage. – CuriousGuy Jul 3 '16 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.