2

I have a CUPS printer (HP Photosmart 2575 All-in-one), connected to a Raspberry Pi via USB. I have added this printer to PCs running Windows 7. When these PCs upgraded to Windows 10, the printer remained working.

However, when I got a new PC that was pre-installed with Windows 10, I have been unable to connect it to this network printer; the printer is always displayed on the PC as in an error state and I cannot print (the CUPS interface has no history of the print job being sent to the printer).

Obviously the problem is with my new Windows 10 PC and not with my Raspberry Pi or printer. I can print from the PC if I connect the printer to it directly, so it is not a printer driver issue. The problem appears to relate to connecting to the printer over the network.

The Windows printer setup wizard cannot discover the printer. I manually copied the settings from one of the PCs that was originally Windows 7. The network address of the printer I'm using is 192.168.1.55:631/printers/HP_Photosmart_2575 (taken from the CUPS web interface).

How do I solve this problem?

  • It would help if you expand your question with some details. What is the printer model and have you loaded a driver for it on the problem machine? What are the printer connection and addressing details on the working machines. Have you duplicated all of the settings from the working machines? Have you tried clearing the spooler? – fixer1234 Jul 3 '16 at 20:02
  • Details. The printer is a HP Photosmart 2575 All-in-one. The driver is installed on my PC that came with Windows 10. I have added the printer in the same manner as other non-Windows 10 PCs. I have duplicated the settings. I have cleared the spool and deleted/added the printer multiple times. – Mowing Bar Jul 3 '16 at 20:27
  • Try connecting the printer directly to the problem PC as a test. That should discriminate a driver issue vs. a communication problem. Did you configure the printer on the problem machine by having it discover the remote printer or by manually entering the settings? You shouldn't require special software, but sometimes the settings can be finicky. – fixer1234 Jul 3 '16 at 20:52
  • I connected the printer to the Windows 10 PC via usb and was able to print like normal. The PC cannot discover the printer so I entered the settings manually (although I copied them from a machine running Windows 7). – Mowing Bar Jul 4 '16 at 8:01
  • Can it not discover the printer because it doesn't have a wizard to do that or because you tried the wizard and it couldn't find it? What are you using for the network "address" or specification of the printer? By the "error state", does the printer, itself, go into an error condition, or do you just get an error message on the problem PC (if so, what)? – fixer1234 Jul 4 '16 at 8:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.