25

This question already has an answer here:

I just shut down Windows and rebooted into Linux. When I try to enter the Windows partition it says Linux cannot mount it because the Windows partition is hibernated. This means that Windows 10 only hibernates instead of shutting down. How do I actually shut down?

marked as duplicate by Ƭᴇcʜιᴇ007, random Jul 4 '16 at 4:04

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 3
    This isn't mentioned in the answers, but if you hold the shift key while shutting down, it disables the hybrid shut down temporarily. – Daniel M. Jul 4 '16 at 1:50
  • 1
    This whole thing feels like a bizarre semantic solution to a technical problem. "People are complaining about the boot times in Windows." Solution: "Change the meaning of 'boot'". – jrh Feb 20 '18 at 15:49
32

This is expected behavior.

Windows 8 has a new form of shutdown which is also present in windows 10, which closes all programs and then hibernates the computer so the next time you start windows it starts very fast.

This is the same reason why it takes much longer to reboot the PC than to power off and then power on.

Here's how to disable the Hybrid shutdown (also known as fast startup)

  1. Right click the windows startmenu button and choose Power Options
  2. click on Choose what the power button does
  3. If at the top there's a windows UAC shield with Change settings that are currently unavailable, click it and give a Yes or password to reopen the dialog with administrative privileges.
  4. At the bottom below Shutdown settings it will say Turn on fast startup (recommended). Uncheck this and press Save changes

Now, when you shutdown your pc, it will shutdown normally, and it won't go into hibernation.

  • 2
    This "FEATURE" also interferes with "Wake-on-LAN" and full computer shutdowns for certain computer brands. It's annoying to push the power button and have the computer fully shut down and then do a partial restart instead of hibernating. – Fiasco Labs Jul 3 '16 at 21:05
  • It's a quick crutch for not having an initrd I guess – Mark K Cowan Jan 30 '17 at 11:07
7

This means that that Windows 10 fakes you when says that it did shut down your computer

Sort of correct. The standard Windows 10 shutdown is not the shutdown you expect it to be. It shuts down USER processes, then hibernates the kernel.

It does not do a normal full shutdown.

Advantages to this are faster boot times. Downside is that the operating system is not fully shut down. Filesystem information might still be cached and changing the contents of the disk may cause windows to crash when you resume from hibernate after the previous shutdown.

Solutions:

  • Shut down fully (E.g. shutdown /s as mentioned by Little Alien).
  • Disable fast boot in windows.
  • 1
    In most cases, faster boot times... We've had issues with certain Dell and HP machines where reverting to full shutdown delivered reliable restarts in all units and faster boot times in about half the machines. It's a feature that's not quite ready for showtime. – Fiasco Labs Jul 3 '16 at 21:11
  • 3
    It is a feature which annoys me. Shutdown should be shutdown. Hibernate is hibernate. If you add a max of those two then they shoukd have called it something like "Hyper fast uber partial suspense down" or something like that. :) – Hennes Jul 4 '16 at 10:42
3

I have discovered that

shutdown /s

helps

  • "helps" how? Does it force windows to power down properly rather than hibernating? – underscore_d Jul 3 '16 at 18:35
  • 1
    @underscore_d Have I had any other problems? The hibernate preventing the disk mount was the only problem that I reported, isn't it? – Little Alien Jul 3 '16 at 18:41
  • 1
    But it also answers the question. With this command you achieve the true shutdown, which was requested. – Little Alien Jul 3 '16 at 19:02
  • 1
    Not saying it doesn't!All I meant was that - if you weren't the OP, as I wrongly thought - it would've been preferable to explain "helps". We get users answering threads with similar things, saying 'try this; it works', and sometimes it's not clear to what they're referring or not directly relevant. But as you're the OP, it obviously refers to your post and is very relevant! – underscore_d Jul 3 '16 at 19:15
  • Actually, if you were to just get into an elevated command console, and ender powercfg/h off, you would disable hibernate, get rid of hyberfil.sys (freeing up something like 256mb disk space) and all you would have to do is click the power button as normal. – NZKshatriya Dec 20 '16 at 1:27
3

You can make the drive mountable, like the second answer explains, by running

sudo ntfsfix /dev/sdXY

where X and Y are the drive letter and partition respectively.

Make sure it's installed by running sudo apt-get install ntfs-3g on Ubuntu.

This takes away the need to reboot again, and it works on GPT drives, which remove_hiberfile doesn't do.

  • 1
    Does this not amount to killing the suspended Windows OS instance? This is a bit like powering off the machine. – usr Jul 3 '16 at 15:01
  • 2
    @usr a lot of the time Windows does do a full shutdown, but the problem still remains. This is good for that and also adds a bit of convenience, if you don't care about the hibernation session. – TheWanderer Jul 3 '16 at 17:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.