I'm running into a weird issue with windows 10 dns resolution when connected to a VPN connection. VPN tunnel is provided by an ASA configured in split tunnel mode.

The issue i'm having on 2 windows 10 machines is that i'm not getting any kind of dns resolution from ping of web browsers, however nslookup resolves just fine.

outputs when connected to the vpn tunnel:

ping to google.com

ping google.com
Ping request could not find host google.com. Please check the name and try again.

nslookup to google. com

    > google.com
Server:  nsc5.so.cg.shawcable.net

Non-authoritative answer:
Name:    google.com
Addresses:  2607:f8b0:4009:801::200e

pinging the resulting address

pinging with 32 bytes of data:
Reply from bytes=32 time=103ms TTL=54
Reply from bytes=32 time=106ms TTL=54
Reply from bytes=32 time=102ms TTL=54
Reply from bytes=32 time=103ms TTL=54

    Ping statistics for
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 102ms, Maximum = 106ms, Average = 103ms

I looked at the logs on the Cisco ASA, no traffic reached it I tried disabling IPV6 I tried increasing the metric on the LAN connection to 15

Still no DNS resoluton for ping of web browsers.

  • 1
    That is probably caused by a firewall. – Julie Pelletier Jul 4 '16 at 5:08
  • Did you try disabling all security on those machines? – Julie Pelletier Jul 4 '16 at 5:14
  • disabled firewall on the clients no change. – briodan Jul 5 '16 at 6:17

When you are connected to a VPN, you are connected to the remote network - and thus, your local DNS settings will be different from your remote's records. This is the trouble you're seeing.

The answer would be found in your remote network's DNS settings. This will entirely depend on how the site is set up. It does help sometimes to use ipconfig \flushdns to clear the local DNS cache on your machine so it doesn't confuse the local and remote caches.

  • remote network is configured to use the same dns servers as the local network. all communication to the remote network takes place via IP. DNS resolution is needed for internet access which takes place through the split tunnel. Have flushed dns and reset the IP stack on both machines no change. – briodan Jul 5 '16 at 6:22
  • If it isn't hitting the ASA, it seems like it's still local. How is your NAT/PAT configured when connected to VPN, and are they configured using ASA or router? – SomeGuy Jul 5 '16 at 18:43
  • on the client side its a basic home router handing NAT. – briodan Jul 5 '16 at 23:29
  • What's handling your DHCP and DNS presently? Is it the ISP provided router? – SomeGuy Jul 6 '16 at 3:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.