3

On my linux machine I am writing a PAM module for two factor authentication (https://github.com/kb100/signal-authenticator). It works on an opt in basis so if a user doesn't have a .signal_authenticator file the module just returns success. When sshing into the machine, it always tells me

Authenticated with partial success.

after the public key authentication succeeds. This is a nice intermediate message to see for those who have opted in to two-factor authentication, but for users who have not opted in it is confusing. They wonder why their authentication was only partially successful whereas in reality it was fully successful.

Is there some way to change this message or stop it from occurring?

  • what openssh version and distro? Can you provide whole log? – Jakuje Jul 4 '16 at 20:53
0

I had the same problem, it is logged from openssh via logit. I was only able to disable via client side configuration LogLevel, configure it in .ssh/config like this:

Host *
    LogLevel ERROR

PS: There might be a mechanism to populate a default client side configuration on the server, I did not find it yet. Please feel free to edit or let me know a short pointer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.