I'm experiencing intermittent port opening issues. I have a server which uses TCP running on port 8080 in CentOS 6. iptables is disabled and port 8080 shows it is LISTENING for traffic.

Here is a simple diagram on how the network is setup: Internet ↔ modem/router (ARRIS TG862S) ↔ router (LINKSYS WRT1900AC) ↔ server.

I can access the server from any device hanging off the 2 routers behind my modem. I can also ping and do successful traceroutes from another device located in a different country. traceroute ends at my modem's IP (ICMP disabled on my routers).

ARRIS modem/router is routed with NAT. WAN IP is DHCP (but hasn't changed over the course of a week and this project). DMZ is enabled with the WAN IP of the IP given to me by my ISP and Private IP of my LYNCSYS router ( Firewall is disabled. Statically assigned IP address for the LYNCSYS router (

LYNCSYS is connected to the ARRIS modem via Ethernet. NAT is enabled. Firewall is disabled. Port Forwarding is enabled - External/Internal port 8080, both TCP and UDP. Static IP address assigned to my TCP server (

TCP Server running on CentOS6, port 8080. Connected to LYNCSYS router via Ethernet cable. iptables disabled. Has Internet connectivity.

I'm using canyouseeme.org in order to verify that the port is open. Normally, canyouseeme.org cannot detect port 8080 open. BUT, if I delete the port forwarding out of the modem/router, re-add it, and then immediately check canyouseeme.org, port 8080 is shown as open. But, after about 10 seconds, canyouseeme.org reports the port is closed. I have screenshots to prove it. At one point I could access the server for about 60 seconds, then it went down.

Thinking that there may be an issue with canyouseeme.org, I also tested for open ports with http://www.yougetsignal.com/tools/open-ports/. Same thing, port 8080 closed unless I delete the port-forwarding in the router and then port 8080 only stays up for less than 10 seconds.

It sounds like port security to me, but then again... why would it create a flapping effect? Why when I delete the port forwarding out of my router, and re-add, the port stays open for a few seconds?


I put the router/modem in "bridged mode" instead of "routed with NAT". Fixed the problem.

  • Can you expand upon how you achieved that? It would help others with a similar issue in the future. – Burgi Jul 7 '16 at 7:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.