24

Since Firefox 47 multi-process option Electrolysis (e10s) is enabled, but I am afraid, my Firefox still only uses one process.

There are a lot of options fingering with this subject in about:config:

browser.tabs.remote.autostart
extensions.e10sBlockedByAddons
extensions.e10sBlocksEnabling

How can I verify that all options are set right?
Which options enable/disable the multi-process capability?
How do I find out if an Addon blocks this option?

  • My configuration is: browser.tabs.remote.autostart : true, extensions.e10sBlockedByAddons : false, extensions.e10sBlocksEnabling : true . – t9toqwerty Jul 5 '16 at 11:00
  • The first two options browser.tabs.remote.autostart and extensions.e10sBlockedByAddons is important and third extensions.e10sBlocksEnabling doesn't affected much . One important point is that extensions.e10sBlockedByAddons : false may break some of your addons. – t9toqwerty Jul 5 '16 at 11:10
  • @Thor, can you post this as answer, so i can reward you? – rubo77 Jul 14 '16 at 23:54
  • I am glad that you find my comment useful . Posted that as an answer but it seems that you answered it way better than me. – t9toqwerty Jul 16 '16 at 12:42
27

Open the site about:support in Firefox, which indicates if e10s is enabled.

There is a line "Multi-process staged rollout", which would be set to true if e10s is enabled. Also look for a number higher than 0 in the "Multiprocess Windows" entry (this is translated to your locale, e.g. "Fenster mit mehreren Prozessen" and "Web-Inhaltsprozesse" in german).

e.g., accessibility, add-ons can trigger disabling this feature.

On this site you can check, if add-ons, you are using are compatible: http://arewee10syet.com/. There is also a mozilla site to check compatibility, you find the addon-id in the extension-filenames in your profile folder, for example the "Tab Groups" add-on has the id tabgroups@quicksaver and is incompatible with e10s.

If you would like to opt-in to test the feature anyway, open about:config and toggle browser.tabs.remote.autostart to true. On your next restart, e10s should be active.

Force Enable

If you've tried enabling e10s but about:support indicates that e10s is disabled (e.g., accessibility, add-ons can trigger this), you can force e10s on for testing purposes. Within about:config create a new boolean pref named browser.tabs.remote.force-enable and set it to true. This is not encouraged, use it at your own risk!

(I tried it anyway and it worked, even with Tab Groups Addon still enabled but it's risky!)

Source: https://wiki.mozilla.org/Electrolysis#Force_Enable

  • 1
    browser.tabs.remote.force-enable worked for me. (The normal settings kept getting changed on start back to single process.) – falsePockets Jan 21 at 4:37
13

My configuration is:

browser.tabs.remote.autostart : true

extensions.e10sBlockedByAddons : false

extensions.e10sBlocksEnabling : true

After these setting my about:support is showing that multiprocess Windows is enabled by user(me).

enter image description here

The first two options browser.tabs.remote.autostart and extensions.e10sBlockedByAddons is important and third extensions.e10sBlocksEnabling doesn't seems to affect much. One important point is that extensions.e10sBlockedByAddons : false may break some of your addons.

  • Why browser.tabs.remote.autostart? That doesn't Sound related – rubo77 Jul 16 '16 at 13:04
  • 2
    @rubo77 The word "remote" here really mean "E10s". It refers to "process", in case you are wondering. – Marc.2377 Nov 25 '16 at 4:47
  • 1
    In my case setting extensions.e10sBlockedByAddons=false for FF v53 was enough to see 1/1 (Enabled by default) in about:support. – dma_k May 20 '17 at 12:24
  • 1
    Hi @dma_k , It seems that extensions.e10sBlockedByAddons not available in my FF 53 (Ubuntu X64) anymore. BTW thanks for your info. – t9toqwerty May 20 '17 at 14:08
0

I opted out of multi-processing in version 64.0.2 of Firefox by going to about:debugging#workers and click Opt out of multiple content processes:

service worker debugging

I didn't make a mental note of which config option it was changing, and once opted out, there was no button to opt in!

Fortunately, I found the config value: dom.ipc.multiOptOut. The value should be empty.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.