2

I'm trying to add a "Tail" entry to the shell context menu for .txt files, but whatever I do the option just does not appear.

My .reg file looks like:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\txtfile\shell\Tail]

[HKEY_CLASSES_ROOT\txtfile\shell\Tail\command]
@="tail.exe -f \"%1\""

It worked fine in Windows 7. Has this feature been disabled in Windows 10 (64-bit)?

How to make it work again?

==EDIT==

Some additional findings:

The default Open action is associated with Notepad++.

If I choose the built-in Notepad application as the default Open action, then my "Tail" menu item shows up. But as soon as I choose Notepad++ or any other app as the default Open action, my custom context menu item disappears.

  • The feature is not disabled. Which program have you set as the default for opening .txt files? – w32sh Jul 5 '16 at 11:26
  • Notepad++ is my default Open program for .txt – rustyx Jul 5 '16 at 11:35
2

This registry setting should help.

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Applications\notepad++.exe\shell\Tail\command]
@="tail.exe -f \"%1\""

Only downside is that "Tail" would show up for every file type associated with Notepad++. If you don't want that, post back so that I can make another REG file that applies only for .txt files.

  • Thanks! I can live with the "downside". But just out of curiosity was wondering how to make it apply only to .txt files. – rustyx Jul 5 '16 at 14:56
  • 3
    To apply the setting for .txt file (per-file type basis), implement the menu here: HKEY_CLASSES_ROOT\SystemFileAssociations\.txt – w32sh Jul 5 '16 at 16:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.