I have windows 10 and fedora 20 in my laptop(Dual boot). I wanna install fedora 24(by replace it on existing fedora),I made bootable usb disk from fedora 24 iso file with LiveUSB Creator, but during the installation, when I end my partitioning and mounting (eg /home, /boot and etc), I get this error:

No valid bootloader target device found. 
For UEFI installation , you must include an EFI System Partition on a 
GPT-formatted disk, mounted at /boot/efi.

My BIOS is legacy mode and it cannot be changed to UEFI mode(also for booting from usb, the usb is booted only in legacy mode). I installed fedora 20 years ago but now I can't install fedora 24 for this issue. I googled many hours and I tried many solutions, but still my problem is not solved, I am very tired now, Pls help me, tnx.

  • It sounds like you booted the USB drive in UEFI mode though. If it's not the case, it could be a bug of the installer.
    – Tom Yan
    Jul 5, 2016 at 13:40
  • @TomYan Yeah, and I can't change it to legacy mode, because my bios doesn't supported.
    – ThisIsMe
    Jul 5, 2016 at 13:46

2 Answers 2


Finally I solved my problem with reinstall fedora 24 with DVD disk(not USB), because always my USB is booted in UEFI mode and I couldn't to change it to lagacy/BIOS mode(for my BIOS). In this case, when DVD is booted, the BIOS let me to choose a mode from UEFI mode and BIOS mode, I chose BIOS mode and installed it.

  • Yes, pressing F8 have 2 options to select from, one the UEFI and another normal. We can do the same without DVD. Jan 13, 2018 at 20:39

In the bootloader options I selected the Legacy USB mode and not UEFI. Start the install process again and it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.