Recently I deleted some folders from **C:\Windows** directory with file names like this: $some_name_Uninstall$, which are the files of the patches, which were installed on the OS. It seems like my office placed the icons in some of those folders and now all xls and doc files have no icon. (I mean no Office icon)

I couldn't find a solution for this till now.

Please advice if someone had such problem and/or knows the solution.

p.s. I have 7 years experience with Windows XP, so please don't ask me to do simple things like associate with files again or something like that. I tried a lot of things. Uninstall and install is not a way out.

Thanks for any information!

  • 7
    I have experience, don't ask me for simple ... this is bad explanation. Simple/obvious for one is the the same for others. With statement like this there's a risk noone would try to help you, just because the chance she'll be shot down for just trying to help you. Either list the things you tried, or remove this statement - you have more answers. Noone has crystal ball to check what you tried, or what you consider "simple". Pls, check this: catb.org/~esr/faqs/smart-questions.html
    – Sunny
    Feb 16 '10 at 21:05

Try this in Explorer the Menu "Tools" - Folder Options - Filetypes go to XLS, DOC, PPT, PPS, ...) click on "Advanced" and choose a other Icon.

the default-Icons are stored here (on my PC) C:\WINNT\Installer{90110409-6000-11D3-8CFE-0150048383C9}\

mostly the same Icons are in the Programs-*.exe-File here: %ProgramFiles%\Microsoft Office\OFFICE11\EXCEL.EXE

and so on for the other Office-Applications.

  • i got a other Idea: try to perform a "Repair installation" of your Office from the Control Panel/Software (if you have a Office-CD at hand) i think it will copy the required files back to your disc. (no guarantee for this)
    – Crujach
    Feb 18 '10 at 9:53
  • +1 => Repair installation and all things will return.
    – Anotomix
    Dec 4 '10 at 10:45
  • If you DO use the Tools->Folder Options - then do NOT forget to first use the RESTORE button if it is available. This clears out anything that was put onto the icon PRIOR to you trying to fix it. Then select the file type and click on the Advanced button like Crujach says. Also do NOT forget to delete anything weird in the middle box. I found a "Convert file" command in there as well as some knock-off PDF viewer. Got rid of both, changed the icon back to Adobe Reader and all was good. :-) Mar 1 '16 at 5:14

Easiest way I have found to deal with file extension issues is to go into the registry and manually edit the key related to the file extension you are dealing with. Press [WIN + R] then type regedit and go to the HKEY_CLASSES_ROOT folder. All extensions for all known file types are listed at the very beginning of that that folder. Simply delete the folder related to a file type and then that file type will no longer be associated with any program, then you should be able to re-associate the file types with the program you want them to open with. If that does not work you can try to build the key manually. Just look at a file extension that does work (like .pdf) and make your .xls key look similar.


If all else fails try an icon cache rebuild



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.