0

I would like to add a shared folder in vmware-workstation, but the vmrun command line is just returning a generic error message.

$ vmrun -T ws enableSharedFolders default.vmx
Error: There was an error mounting the Shared Folders file system inside the guest operating system

I'm looking first for tips to debug further from here.

How I got here: I'm running VMWare Workstation 12 Pro on Windows 10 Pro and I'm trying to setup a docker host (which in turn uses the file share for a lot of development sugar). So the VM image is boot2docker. I'm using a beta driver for workstation - and it is internally failing on the call to vmrun enableSharedFolders during setup.

Inside the running boot2docker image, I have found /var/log/vmware-wmsvc.log to get a few lines each time I run enableSharedFolders - that output looks like:

[Jul 05 18:53:21.412] [ message] [vix] ToolsDaemonTcloReceiveVixCommand: additionalError = 17
[Jul 05 18:53:21.413] [ message] [vix] VixTools_ProcessVixCommand: command 62
[Jul 05 18:53:21.413] [ message] [vix] ToolsDaemonTcloReceiveVixCommand: additionalError = 17
[Jul 05 18:53:21.480] [ warning] [vix] ToolsDaemonTcloMountHGFS: vmhgfs-fuse -> 32512
[Jul 05 18:53:21.497] [ warning] [vix] ToolsDaemonTcloMountHGFS: vmhgfs mounting -> 256
[Jul 05 18:53:21.497] [ message] [vix] ToolsDaemonTcloMountHGFS: returning 20050 2
[Jul 05 18:55:41.537] [ message] [vix] VixTools_ProcessVixCommand: command 62
[Jul 05 18:55:41.537] [ message] [vix] ToolsDaemonTcloReceiveVixCommand: additionalError = 17
[Jul 05 18:55:41.537] [ message] [vix] VixTools_ProcessVixCommand: command 62
[Jul 05 18:55:41.537] [ message] [vix] ToolsDaemonTcloReceiveVixCommand: additionalError = 17

But I also don't know where to go with that. Other searching (vmware support mostly) suggests mounting over the network instead of using vmware-tools. I'd like to avoid going down that path to avoid custom users and config on my host.

0

I was able to get the latest version of docker-machine using vmware workstation working, thanks to an update from the author. Version 1.0.10 worked for me.

The main diagnosis I was using, vmware enableSharedFolders continues to fail, so that's mysterious, however the vmhgfs-fuse based folder mounts within the boot2docker vm are working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.