0

I'm trying to find out why whenever I open up the first Finder window (I press on the Finder icon and there is no previously open Finder window), my ~/.ssh folder is shown instead of my home folder which is configured on the "New Finder windows show" preference.

I thought this was related to showing/hiding hidden folders but I've tried changing those settings and it doesn't seem to make a difference.

Other things I've tried:

  • If I rename my .ssh folder to something else, for example .ssh2, the first Finder window opens my home folder, not .ssh2. As soon as I rename it back to .ssh I have that folder open again.
  • I tried also creating a new folder, .ssh but same behaviour. The newly created directory is opened with the first Finder window.

Note when I ask for a New Finder Window I do get my home directory open; it's just the first Finder window. If I close all Finder windows and open Finder again, .ssh is opened again.

Does anybody have any suggestion on how to troubleshoot this further?

I'm running El Capitan 10.11.5

1

After some more troubleshooting I found that ~/Library/Preferences/com.apple.finder.plist had some references of my ~/.ssh folder which was suspicious. I must have directly or indirectly added that somehow.

I backed up the file and deleted the .ssh/ from that file and things started behaving as expected.

I've also read some suggestions when having Finder issues regarding trashing that file completely and letting the system re-create the file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.