9

Is there a way to prevent the screen from being turned off when a laptop's lid is closed? The power-action for closing the lid is already "do nothing".

  • More info please. Firstly, why do you need that. Maybe there's smoe other possibilities to do what ou want. Secondly, what's the videosystem. Intel? ATI+Intel? GTX+Intel? – Alexandr Kovalchuk Jul 6 '16 at 21:04
  • That setting should be enough. If you open the lid directly after closing it, is the screen still on? You may be looking at the if you do nothing, turn off the screen setting too. – LPChip Jul 6 '16 at 21:12
  • @AlexandrKovalchuk It's just Intel. I think it's built in. – ispiro Jul 6 '16 at 21:17
  • 2
    I have this same problem and it's really pissing me off. ASUS ROG Strix, NVidia 980m. It is set to "Do Nothing" but the display clearly goes off when the lid gets a couple inches from the keyboard. When you open it again, you can see the entire screen do a weird refresh. This is causing me to be unable to gamestream while lid is closed which is inconvenient. – Devil's Advocate Feb 14 '17 at 4:38
  • 2
    @Scott Sometimes, it's a hardware switch - in which case, there might not be anything you can do about it short of physically removing the sensor responsible for it. If you want to make sure it's not the OS, try while in the firmware config menu - if the screen still turns off there, it's not the OS. Or try while booting from CD/USB. – Bob Feb 14 '17 at 5:15
8
+50

Go to gpedit.msc and setting the Select the lid switch action options for both "on battery" and "plugged in" to "Enabled" and then restart the PC.

Navigate via gpedit.msc | Computer Configuration | Administrative Templates | System | Power Management | Button Settings | set both the "Select the lid switch action" options to Enabled. Be sure to set the Lid switch action to a value of Take no action as well.

Be sure to fully power cycle and reboot the machine once you apply these settings

enter image description here enter image description here

3

Replacing the ACPI Lid device's driver as described in this answer is the only thing that has ever solved this problem for me. It's so worth the drawbacks if you're using external displays, being able to close and open the lid without fullscreen apps crashing (e.g. old games) or messing up all the windows that you've carefully laid out on multiple monitors.

  • I've always thought this was functionality controlled by the BIOS, given that lid close => screen off also happens before Windows is booted. But I guess it makes sense Windows can override it via ACPI seeing as ACPI allows it to do the same thing with the power button etc. TIL... – qasdfdsaq May 30 '18 at 19:14
1

Since your operating system is saying "Do Nothing", the issue is not likely settings within the operating system. Check your system's firmware configuration. In other words, go into BIOS setup or (U)EFI setup.

Details may vary between different computers, but look for options related to screen, power, sleep, performance, or hibernate.

  • Not the OP, but placed a bounty. No related settings in the BIOS on my ASUS. :( – Devil's Advocate Feb 14 '17 at 5:05
1

What's the use case for this? - answers kind of depend on that.

If this is to stop the "desktop shuffle" cause by closing the lid with an external then setting the external display as the primary helps - until you unplug it while the machine is on.

If it's the actual display You need on it might be harder as this is controlled by a hardware switch (old laptops used to have a little button at the top) possibly inside the hinge on more modern machines.

Depending on model it might be in setup menu, but equally it might be a physical power supply that disconnects as well.

I don't know how but setting up an emulated external display could well provide you with some functionality as the machine will believe it still has an active display.

  • Not OP, bounty provider, but for me this is related to Gamestream. I stream to my shield from my laptop but if the lid is closed it constantly drops frames and loses connections. If I have my laptop open on the table next to me everything works fine, as soon as I close the lid it starts getting choppy and eventually disconnects. Even if I start the session with the lid closed it is still sketchy. – Devil's Advocate Feb 16 '17 at 15:23
0

If your problem is the weird refresh that happens when you open the lid : I had the same problem and found that it was coming from the driver of my graphic card (NVidia GeForce GTX 965M). I tried different version of the driver without any improvment.

The solution I found was to switch to the basic video card driver provided by Windows (you do this using the Device Manager). Now, no more weird refresh for me.

0

I would like to suggest Policy Plus for this answer.

Policy Plus is an open source alternative to gpedit.msc for those who don't have Professional Windows verions and I was able to follow the guide by Pimp Juice (current top answer). Be warned though, you'll have to grab the current polices by going to Help -> Aquire AMDX File in Policy.

-1

This is an old thread, but I just found an answer that works for me...

When you close the lid and your connected monitors turn off, with the Do Nothing option on, simply move your mouse to wake the extended monitors up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.