2

I have created a hosted network on Windows 10 using the "netsh" commands, I have also shared the main internet connection with the hosted network.

But no matter what I do, when I connect my android (6.0) phone to the network, it says "connected, but without internet". How can I make it connect?

Please read everything I tried before posting repeated answers:

  • Used the same method everyone teaches: netsh wlan set hostednetwork mode=allow ssid=mynetworkid key=mypassword keyusage=persistent
  • My wifi card is enabled and supports this feature, I was able to start the network (netsh wlan start hosted network) and the network is visible from the phone.
  • I did share the connection from the ethernet adapter (where my computer receives internet from) to the newly started hosted network (and tried restarting the computer after that and restarting the network)
  • Checked if "Automatic WLAN configuration" and "ICS" services are turned on before trying to connect.
  • Checked if the energy configurations for allowing the computer to disable the device for sleeping are according to other users' solutions
  • Tried static IPs too, the result is the same. Connected, no internet.
  • Tried enabling all services inside the "share connection" configurations (Except controlling desktop).
  • There is no option to bridge the hostednetwork to the ethernet.
  • Tried even some nonsense (is it?) stuff such as creating passwords with exactly 8 characters and changing the network name.

Does anyone have another solution for that? Is there a possible problem with the IPs, gateways and DNS? (I don't understand these quite well), but I followed some standard procedures other users did such as trying the google DNS (8.8.8.8, 8.8.4.4) on the phone and on the hosted network. Used static IP's with the hosted network adapter (IP+1), and gateway = IP. I don't know what else to to....

1
  • try running a HTTP proxy on your Win 10. Then configure your Android 6 to use this proxy. For proxy you can try [Fiddler] telerik.com/fiddler
    – AEonAX
    Jul 7 '16 at 3:58
1

Did you try turning on the Routing and Remote Access service? When I turned it on thanks to the suggestion in https://codeyarns.com/2014/06/13/how-to-fix-internet-access-on-windows-hosted-network/ and recreated the hosted network it worked.

1
  • Well.... I ended up buying an actual WiFi router. But if I remember well, yes, I activated that service too.... Oct 13 '16 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.