3

Alright, you're my last chance on resolving this problem that I have been trying to fix for a couple of months so far.

Problem

My gigabit Ethernet speed switches from 1Gbps to 100Mbps frequently. This issue occurs usually, and there is no time pattern in switching between speeds. It switches by itself just like that. Sometimes, it sticks at 1Gbps for days and then switches to 100Mbps, and sometimes it just switches in a matter of hours. Same thing happens conversely.

More details

I just moved from United State to another country, so I am a 3 months of experience in this country. I also use the same laptop, and I hadn't have any problem in using a gigabit connection.

I am connected to internet through fiber optics with a maximum speed of 200Mbps. The network diagram is as following :

Cable Box → Router → PC

The router is provided from the ISP, which they disabled most of the features(options) that can the user change (as a protection of misuse) leaving the common features editable (WAN, LAN, Wireless..etc). So, not all options in the router can be edited. I called them as I want to request a replacement to a new modem (not a router), so I can buy a router and connect it to the modem, like what I used to do when I was in U.S , but they told me they only provide routers. (AND NO I haven't changed it yet, still waiting for the ISP to accept my request of a replacement). The router has 4 GE ports and they're divided by 2 categories. LAN 1 & 2 are for general purposes (for computers and other devices), and LAN 3 & 4 are for TV-Box service. My cat 6 cable is connected to LAN 1, and there is a cat 5 cable on LAN2 for my brother's computer in a different room.

What I have tried so far

  • Tried 4 different CAT 6 cables from different manufactures. (No Luck).
  • Tried to force the connection speed using "Speed & Duplex" parameters on my laptop, but there is no 1Gbps option in the drop-down list (no clue why), so left it at (Auto Negotiation).
  • Tried to search online for a solution, read, applied. (No Luck)
  • Tried to update drivers, uninstalled, reinstalled them (As I have found some complaints on my current E2200 network adapter). (No Luck)
  • Tried to test the cables on different computers, and they work like a charm, but since I couldn't hold these computer and put them on test for a couple of days, I didn't consider it as a full test.
  • Tried to connect two computers via Ethernet, with the same cable, and it works with 1Gbps of speed perfectly.

What's Next I am thinking that this issue is from the router, While I've tried to change settings, but as I mentioned is protected from the ISP, so I am waiting for the ISP to send a replacement, which will take months to be replaced. So, I am trying to figure out the problem, because it bugs me, and I need to know how to fix it. As most of the online solutions didn't work.

Comments Answers:

  • Power Management is on High Performance, and modified the advanced settings to a %100 of working performance with all hardware.

  • Power Savings is disabled in all hardware including the network adapter.

  • Windows NIC connector tested with different computer, and it seems in good condition, has no reflects nor bad reports. Plus, it was working great with Linksys EA6900 AC1900 for over an year with no issues with a gigabit connection.

  • Flow Control Option was set to Rx & Tx Enabled, then turned off (Disabled).

  • Maximum length of using 1Gbps connection was 3 days in a row, then the connection reconnected by itself with a 100Mbps speed.

  • The router LAN lease time is set by default to 3 hours.

  • Disconnected LAN 2, and kept only LAN 1 connected. (No Change).

  • Switch Killer E2200 NIC into Qualcomm Atheros AR8161. (No Change)

  • Turned back my Killer's E2200 and updated the drivers from the Killer's website. (No Change)

I tried to be as much detailed as possible.

Update 7/20/2016

Today, I was reviewing my SSD settings to optimize its performance. So, I have made these changes :

  • Disabled Hibernation Mode
  • Disabled Virtual Memory (As I have 32GB of physical memory)
  • Disabled Prefetch / Superfetch
  • Enabled Over Provisioning (OP) for my SSD.
  • Disabled Ethernet, Wireless, Bluetooth, Adhoc.
  • Used CCleaner to clean up the temporary files.
  • Next, Restarted my computer, and then re-enabled Ethernet, WiFi, Bluetooth, and Adhoc.

When I enabled Ethernet, it just connected with a 1 Gbps. I was surprised because for the last 19 days my Ethernet speed was stuck at 100 Mbps, and this was the longest time I have experienced in 100 Mbps. I do not know if this solved the problem or not, so I will be monitoring this problem this week and see what happens.

Update 7/26/2016

It has been almost 6 days, and I have not experienced any issue with my connection speed. I am still wondering what was the cause of this issue, but it seems everything is working flawlessly after I optimized my SSD performance settings.

I think I can say this case is closed. Big thanks for those who tried to think through this issue and bring a solution.

  • Is there any performance reduction settings in your BIOS/UEFI firmware like there is for the CPU performance on many computers (especially laptops to reduce battery consumption)...? There may also be some power settings for the device in Device Manager that mentions about reducing link speed when on battery or standby – Kinnectus Jul 7 '16 at 9:07
  • Test the NIC connector for the device you have problems with. It may have a faulty connector wire. – Overmind Jul 7 '16 at 9:32
  • @BigChris, there are some reduction settings in BIOS for CPU and USB. There is nothing related to LAN except two options one for Network Stack and the other one is for Network boot, which I don't use. And for power savings, it's disabled, in fact, my settings is modified to Higher Performance with %100 of performance on all hardware, and always connected to AC, I rarely run the laptop on battery. – iSR5 Jul 7 '16 at 11:45
  • @Overmind, I've already test it, and it seems in a good condition, there is no conflicts in Windows device manager logs, plus it worked with the full speed when I connected to another computer. – iSR5 Jul 7 '16 at 11:50
  • You need to go to Device Manager on your laptop to get the advanced network card settings: This image should help kb.parallels.com/Attachments/kcs-32201/WoL_Windows.png. Your adapter will be different and the screens may have some extra options but there may be a "reduce link speed" options for the manufacturer's tab of options. h30434.www3.hp.com/psg/attachments/psg/… (this is intel but it shows the option) – Kinnectus Jul 7 '16 at 11:50
0

This is the conclusion of the post above:

If you have the same issue, then follow these steps :

  • Make sure your network adapter supports an 1 Gbps connection or higher. (e.g Gigabit Ethernet Controller 10/100/1000)
  • Make sure your router has Gigabit LAN ports (GE).
  • Make sure your ethernet cable is CAT5e, CAT6 or higher.

On Windows Side:

  • Make sure that Speed & Duplex parameter is set to Auto Negotiation. (You can set it to 1000 Mbps/ 1 Gbps manually).
  • Set the Power Management to High Performance and modified the advanced settings to a %100 of working performance with all hardware.
  • Disable Power Savings on the network adapter.
  • Disable Hibernation Mode
  • Disable Prefetch / Superfetch
  • (FOR SSD) Enable Over Provisioning (OP) with %10 of SSD capacity.

Update 8/1/2016

I figured it out, Enabling the Over Provisioning (OP) for the SSD will fix the issue. As I tried to delete it, when I did, the network speed immediately switched back to 100Mbps, and when I set the OP again, the network speed went back to 1Gbps.

Don't forgot to disable the Ethernet and turn off your router, then restart your computer and then power on your router again and re-enable your ethernet.

For more details on what I have experienced, read the full post above.

0

Had the same issue, the NIC synced on 100M, Physical cable disconnect-reconnect solved the problem for few hours Since my SSD is plain without SSD management tool for windows i didn't have the ability to configure Over provisioning. Afters shrinking the data partition on my SSD and reservering 10% of unpartitiond disk for SSD housekeeping the NIC stayed sync on 1G forever

kudos

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.