0

How to format SanDisk Curzer Edge 8GB pen drive when it is half bootable. Because of some laptop's charger issue i could not complete process. Now i want to format it but could not success. I have tried many solution which are available on net but not get success in any of them? Image

2
  • 1
    can you show us the error, if you have tried to format it.
    – AReddy
    Jul 7, 2016 at 9:25
  • you can check the image
    – Pallavi
    Jul 7, 2016 at 9:38

3 Answers 3

0

Try following:

  1. Open "Computer Management"
  2. "Storage" -> "Disk Management"
  3. Make sure to find the correct device on the bottom panel
  4. Right click on the partition rectange -> "Delete Volume"
  5. Right click on the appeared grey area -> "Create Volume"

edit: If that doesn't work, you might need to use DISKPART utility to recreate filesystem and main partition, like in this question:

Start a command prompt, and start the DISKPART console. List all of your disks by typing LIST DISK, then select the proper disk with SELECT DISK # (where # is the SD card). You can then type CLEAN to clear the partition table on the card, effectively blanking it. MAKE SURE YOU SELECTED THE PROPER DISK BEFORE RUNNING THE CLEAN COMMAND!

To create a primary partition to reuse the space on the card, type CREATE PARTITION PRIMARY. This will then reallocate the previously "cleaned" space.

To format, type FORMAT FS=FAT32 QUICK...

(Ignore the SD card being mentioned)

edit 2: If that doesn't work try suggestion from this link:

1) list disk
2) select disk #
3) list volume
4) select volume #
5) detail disk
6) detail volume
7) attr disk clear readonly
8) attr volume clear readonly
9) detail disk
10) detail volume

edit 3: This answer to a similar question suggests that the drive may be faulty:

I understand that you are getting write protection error while
accessing your Cruzer flash drive. The flash drive has detected a
potential fault and has become write protected to prevent data loss.
There is no method to fix this. You will need to backup your data and
replace the flash drive. ...

6
  • The click is disabled. I can't click on it
    – Pallavi
    Jul 7, 2016 at 9:57
  • Added an alternative option, edited the question. Please be careful with it Jul 7, 2016 at 9:58
  • This also doesn't work. The Volume Status is Read only . Can you tell how to change it
    – Pallavi
    Jul 7, 2016 at 9:59
  • I have used regedit to set value to 0 for off the write protect but still it show the drive is write protected
    – Pallavi
    Jul 7, 2016 at 10:06
  • I have tired your Edit 2 , it doesn't work. detail disk show current read only: yes whereelse read only : no
    – Pallavi
    Jul 7, 2016 at 10:22
0

Make sure you are running the Administrator account

  1. Right click the file or folder that is write protected
  2. Click Properties
  3. Click Security Tab
  4. Click Advanced
  5. Click Owner Tab
  6. Click Edit...
  7. Select yourself as the owner then click apply

If it allowed you to take ownership you should now be able to delete the files

1
  • Not successfully.. Again showing error write protected
    – Pallavi
    Jul 7, 2016 at 9:34
0

Open CMD with administrator privileges then go to DISKPART and select the disk then type in ATTRIBUTES DISK, and Diskpart will tell you what you want to know about your flash drive. Most important is the first line Current Read-only State: Yes. This lets us know that, indeed, the flash drive is write protected.

To remove the write protection with Diskpart, type the command ATTRIBUTES DISK CLEAR READONLY. If it works, that will be confirmed by the line Disk attributes cleared successfully.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.