I have 2 devices :

  • PC (debian 16.04) : 10.0.0.56
  • Android device (4.4.2) : 10.0.0.38

They're on the same network, have the same gateway which is 10.0.0.1 but whenever I try to ping from one device to the other, I have a

PING 10.0.0.38 (10.0.0.38) 56(84) bytes of data.
From 10.0.0.56 icmp_seq=1 Destination Host Unreachable

The weird part is that I can still ping other devices (using wifi or not), in the same network with the 2 of them. What is causing this problem ?

Normally, the error "Destination Host Unreachable" means that the ARP resolution for the destination failed. If you run ARP -a on the computer which run the ping command, you should find that the ARP entry for 10.0.0.38 is missing.

My assumption is that the android device enables ARP firewall, so that it will not reply the ARP request.

Hope this helps.

  • When I run arp -a on my PC (10.0.0.56) I have an entry like this : ? (10.0.0.38) at <incomplete> sur wlp1s0 Also, I don't know how to disable the ARP firewall on my android device, there's no setting like this – Nabil B. Jul 7 '16 at 12:07
  • First, sorry about my typo, I've edited the original answer to change the 10.0.0.56 to 10.0.0.38. According to your description, I'm sure that the android device has enabled the ARP firewall. I'm not sure if this setting can be changed by a user. Normally, we need root permission to change such settings. Also, I'm not familiar with the android device. As a network engineer, what I can say is that the ARP firewall is mechanism which prevent the host from responding to any ARP request, so that no one on the same subnet can initiate the connect to the host. It's for security reason. – Steven Lee - MSFT Jul 8 '16 at 5:55
  • Ok I'll search more about the arp firewall. But what I find weird, is that I can still ping other devices in my network with my android device. Also, yesterday the ping from my pc to android worked for a very short time and then got the same error – Nabil B. Jul 8 '16 at 8:08
  • The android device should be able to ping other device, it's normal. Because, it can get the MAC address of other device through ARP. – Steven Lee - MSFT Jul 8 '16 at 8:22
  • Did you ping the PC from the android device? If yes, it can be explained. Because, if the android device starts the communication to PC, it will expose its' MAC to PC, so that your PC are able to access the android device. But the arp entry is dynamic, which means that it will be aged and cleared. So, after a period, your PC can't ping the android again. ARP firewall is one possibility. Anything preventing the ARP response from the android will cause this issue. – Steven Lee - MSFT Jul 8 '16 at 8:26

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.