13
  • Chrome: 51.0.2704.106 m (64-bit)
  • QUADRO M1000M NVIDIA supplied drivers, delivered via device manager force update (update did not affect the issue): 10.18.13.5474
  • Intel HD Graphics 530: 10.18.15.4285
  • Dual monitor, external connected via HDMI cable to DVI input.

When playing HTML5 videos on Chrome, fullscreen videos display fine in the built-in monitor, but if set to display on the external monitor it is just black (with sound).

This does not happen on MS Edge or Internet Explorer (both also current versions).

Workarounds (i.e., fullscreen video in external monitor works when I):

  1. Disable the built in graphics in the BIOS

  2. Disable "use hardware acceleration when available" in Chrome settings

I would like have built in graphics enabled (to conserve battery) AND I would like to use hardware acceleration in Chrome (to get better performance when needed).

Are there specific settings for Chrome in the NVIDIA Control Panel I need to play with? I tried setting Chrome to use the external GPU, but it doesn't solve the problem, so I left it at default (Chrome by default uses the internal GPU, according to NVIDIA's control panel).

Are specific settings in the Chrome flags I should play with?

What else could I try to enable fullscreen video in the external monitor while respecting 1 and 2 above?

PS: I don't play games, so I would actually rather disable the NVIDIA GPU entirely, but if I do that the external monitor doesn't work at all (I assume it is because the HDMI output is connected directly to the discrete graphics adapter)

  • 2
    I have this issue as well. Been so for years now. I have a inking that'll never get fixed. Since it's a niche, high skill level, hardware, cross company bug. Intel & Chrome & Nvidia – Pathfinder Aug 30 '16 at 15:14
  • I have the issue solved in Chrome 53.0.2785.80 beta-m (64-bit), and as far as I recall, also solved in 52.0.2743.116 m. The other issue, bugs.chromium.org/p/chromium/issues/detail?id=627714, still uses the workaround "disable the Intel GPU in the BIOS and run only the nVidia. Chrome can use HW acceleration and this issue does not occur." – Gaia Aug 30 '16 at 19:28
  • 1
    Hi, August 1st 2016, bug still there. Latest updates of everything. Chrome 53.0.2785.89 m, Win10 Pro Up2date, Intel HD 4600 20.19.15.4463 (5/2016), Nvidia GTX 765m 21.21.13.7270 (08/2016). – Pathfinder Sep 1 '16 at 5:59
10

There's a chrome bug for this here: http://crbug.com/622167


Try upgrading to Chrome 52, via the beta channel (or wait for a few weeks for it to be released to stable).

I had what sounds like the same problem on Version 51.0.2704.106 m (64-bit), and after I upgraded to Version 52.0.2743.60 beta-m (64-bit) today it was fixed.

After restarting chrome it seems like my changes only fixed the issue temporarily, as a side-effect of starting chrome when the internal laptop screen was my main display.

I did a few experiments, and found the following:

  • It's not related to HTML5 video, it happens any time you enter full screen mode (by pressing F11 on any page).
  • It only happens when the external monitor is marked as the "main display" in Windows's display settings. Making the laptop's screen the main display and "extending" onto the external monitor made full-screen on the external monitor work.
| improve this answer | |
  • Is your laptop equipped with discrete graphics along an internal gpu? And is your monitor a Dell also? – Gaia Jul 13 '16 at 19:20
  • Issue does not occur when the internal GPU is disabled in the BIOS (display HW is set to discrete only, instead of hybrid). This suggests that the Chrome issue is related to the Optimus software OR the Intel driver. Unfortunately one cannot test the issue using only the Intel GPU, as you cannot connect an external display when only the Intel GPU is on (the HDMI/miniDisplay ports are hardwired to the discrete GPU on my laptop) – Gaia Jul 13 '16 at 19:21
  • My laptop has both integrated Intel graphics and a discrete Nvidia card using Optimus. It seems to happen with anything connected to the HDMI port - I've tried with a Lenovo monitor and a TV. – Styglian Jul 14 '16 at 19:32
  • see comment superuser.com/questions/1098204/… – Gaia Aug 30 '16 at 19:29
9

Quick fix: Startup chrome with this flag: --disable-direct-composition

Pop into the shortcut for running chrome and append that flag to the target like the image below:

Chrome Startup flag

Source jbau...@chromium.com(bugs.chromium.org/u/4122139466/) https://bugs.chromium.org/p/chromium/issues/detail?id=622167#c29

| improve this answer | |
  • I will check on this and report back. – Gaia Sep 1 '16 at 7:08
  • This worked for me. Using Lenovo P50 laptop and setting an external monitor as the main one. Thank you! – Adrian K. Oct 7 '16 at 1:37
  • 1
    This doesn't work for me. I'm using external monitor as my main display and turn off the display for my laptop's screen. Same thing happens on edge & ie, but doesn't happen on firefox. – bysreg Oct 30 '16 at 19:26
0

This worked for me using Alienware 17 R3 with Intel Graphics 530 and integrated Nvidia 980M GTX using external monitor via HDMI:

Chrome version Version 54.0.2840.87 m (64-bit)

Start up Chrome with this flag:

chrome.exe --disable-direct-composition

This was affecting any mode in full screen (F11) using websites, videos, HTML5 or not.

| improve this answer | |
  • Has been sad in this answer: superuser.com/a/1119807/68374. Your answer is better of as a comment to it. – Gaia Nov 12 '16 at 19:16
  • Welcome to Super User! This duplicates another answer and adds no new content. Please don't post an answer unless you actually have something new to contribute. – DavidPostill Nov 14 '16 at 10:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.