0

I have an Excel file that generates reports using VBA. A portion of that process copies data from 1 file to append into another then saves the destination file. The process works on many machines with varying combinations of Windows and Excel. It has now decided to stop working for 2 of my users. These 2 users recently received new desktop computers with 32 bit Windows 7, MS Office 2013 (15.0.4787.1002).

For these 2 users, the VBA prompts with the "Do you want to Save the file?" message. When they click Yes, the procedure completes but the file is not saved. All other users do not get this prompt, the file just saves and closes.

I looked online for updates that cover this behavior and found nothing relating to this problem.

The VBA Code contains:

Application.ScreenUpdating = False
Application.DisplayAlerts = False
…
Workbooks(ModelFile).Close SaveChanges:=False
Workbooks(CurrFile).Close SaveChanges:=True
MsgBox ("Destination Updated")
…
Application.StatusBar = False
Application.DisplayAlerts = True
Application.ScreenUpdating = True

CurrFile closes, but without any changes.

Is there an update to apply or a setting we can change that will fix this behavior?

  • The 2 users: Are they using a "Read Only" version? This might be and will not allow saves because they are not actually permitted in "editing or modifying". Are they on the network and do they have access to these files, writable access. It's only these 2 users? Or the user's machines? Or Both? The machines may need to be updated with accesses on the server. – ejbytes Jul 8 '16 at 0:37
  • @ejbytes - Good questions. No. They are the only users editing the file at the time. Yes, they're on a network and have full access to the file and folder. Yes, it's only these two users on their new machines (their old machines worked). We tested 1 user logged into my machine (64 bit Win 7, Excel 2013) and it worked fine. It's definitely something in the settings on their machines. – B540Glenn Jul 8 '16 at 13:32
  • Seems that it's not a credential problem then. I was going to suggest having the 2U (2 users) log into other machines to see if it works out. Looks like you tested that out. ****** Did you log into their machines yourself and test this? **** If you log into their machine and it fails, then it's the credential not set on the server for these new machines. IP? Max? Static/DHCP? MAC addresses? Credentials. Workgroup? Get a checklist of two good machines and match it against a new machine. – ejbytes Jul 9 '16 at 8:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.