I know this topic has been covered extensively, but trust me, this has not been resolved yet:

I want to do an EFI Windows 10 installation on a MacBookPro8.2 (early 2011) running El Capitan. Using Bootcamp Assistant you can only install Windows in BIOS mode as it converts the GPT disk into a hybrid MBR.

The way around this for most Mac users has been to directly boot into a USB drive containing the Windows ISO file. In this MBP model you have to use the optic drive and perform the installation from a CD as it doesn't let you boot anything from a USB.

However, booting the CD (or anything for that matter) in EFI mode is not permitted. Only the BIOS option shows up, so the installation believes your computer runs in BIOS mode, and asks you to convert your GPT disk into MBR before installing windows (in BIOS mode, obviously).

Trust me in this thus far, I haven't made a mistake burning the installer, I haven't been deceived by a broken USB port, this is an issue with this specific MBP model (8.2, early 2011).

I have tried installing Windows using a virtual machine such as virtualbox from the OSX, and it didn't work either (cannot remember why exactly, it gave me some error during the installation). I even tried connecting the HDD as an external drive into another computer to perform the installation from it, which I'm not sure if it's crazy or not, but it never worked anyway.

I have tried every solution I have found, and failed. I spent such a ridiculous amount of time installing and reinstalling both OS's, and flashing my drive again and again that I finally gave up and just went on with the MBR install. Losing both the fast booting I was promised along my new SSD, and the access to the built in GPU from the Windows OS.

Perhaps only reEFInd creator Rod Smith knows how to make this work, but I'll really appreciate any of your suggestions...

1 Answer 1


It is not possible to run any version of Windows in native EFI mode on that model of laptop. I know this because I have a late 2011 17" MacBook Pro and have spent literally years trying to make it work.

The closest I've ever gotten was running Windows 7 native EFI by extracting the install.wim to the hard drive and manually installing the boot loader and using rEFInd to boot it. But it only ever worked with the Microsoft basic VGA driver (which has crappy video performance and no Direct3D support), and I was never able to get sound working at all -- even with Apple's Boot Camp drivers. I've never had success w/ Win8 or 10, however.

At the end of the day, there are four things working against you:

  • Apple was the first to market with a dynamically-switching GPU. They did this with a hardware GMUX chip of their own design at a time before graphics switching was ever officially supported by AMD, nVidia, or Intel. This chip is invisible to Windows because its memory address lies in the shadow RAM area from the good old DOS days of yore, which Windows still to this day uses as such. Apple solves this problem by locking the GPU to the discrete adapter when the firmware's BIOS compatibility module kicks in. Without this BIOS emulation, Windows sees invalid ROM in this area and can't load the video driver.
  • Apple also wired the display with a custom dual-link DDC such that each channel carries a different clock signal from one GPU or the other to the screen. When OS X switches GPUs, it also switches the laptop panel from one channel to the other. Again, Apple solves this problem in Windows by locking the DDC to a single channel carried by the discrete GPU to the screen. You'll also notice that hooking an external display to your MacBook will also force the discrete GPU to activate. The connection to the integrated GPU is not carried to the Thunderbolt port.
  • Apple really loves hardware switches! Macs also have two audio DSPs in them, controlled by a switch in the headphone jack on the side of your computer. One is analog that powers the internal speakers and headphones, the other is digital for optical S/PDIF connections. This has been a problem even in OS X as some people have reported that the switch gets stuck and they don't have audio unless they insert a toothpick into the jack and jiggle the switch back out. I've had this problem myself. As far as I know, this is purely an Apple thing, as I've never seen a combo headphone/optical connector on a PC. Here again, Windows doesn't know how to handle audio routing unless Apple's BIOS compatibility mode forces one DSP or the other. I don't know if it's possible to use S/PDIF in bootcamp, as I don't have any optical equipment to test with.
  • Lastly, EFI relies on two-way communication between the OS and the firmware, which Apple supported even back in the '90's before EFI was a thing, but which is new to the Windows world. When installing Windows on an EFI PC, Microsoft's boot loader (BCD) attempts to use an Apple-unsupported EFI command to make the system bootable. This is because OS X does not need a boot loader. Apple's firmware knows how to boot their own OS without one, and they've operated for over a decade without having to care what other operating systems think of their EFI implementation. Therefore, bcdboot.exe generates an error when trying to make the system bootable and BCD doesn't understand the way Apple enumerates SATA devices. rEFInd might help here, but you're definitely going to need a 3rd-party utility to create the BCD store for Windows to boot.

It IS possible to boot Linux in native EFI mode on a 2011 Mac. Here's a good write-up that can point you in the right direction. Basically, you use Grub to poke some bytes into the GMUX's memory area to switch off the discrete GPU and then pass some parameters to the kernel to make Intel's driver use the correct signaling for the screen. Even if Grub could poke those bytes into memory before booting Windows, Intel's Windows driver doesn't seem to support the non-standard signaling (or if it does, I can't figure out where they'd need to be set in the registry).

So yeah... Getting Windows to boot native EFI on a 2011 MacBook Pro is like this sweet, tasty fruit that seems like you could almost reach out and grab, but it's juuust barely out of reach, teasing you with an impossible task like the torment of Tantalus.

  • 1
    Well, I guess this means I give up too... Thank you very much for your answer, It's just what I was looking for!
    – user614778
    Jul 29, 2016 at 19:56

You must log in to answer this question.