14

I just downloaded VMware player (I used to use Virtual Box, but I needed Windows Aero, and vbox doesn't support that yet) But it will automatically resize the guest when I resize the window, and I do not want that. I did not see an option to turn it off. Does anyone know?

4
  • 1
    I don't see it either but most options that we are used to with workstation are not present in player.
    – Sky Sanders
    Feb 17, 2010 at 1:09
  • I know this option exists in Workstation...
    – Josh
    Feb 17, 2010 at 3:18
  • Where is the option in Workstation?
    – EMP
    Jan 24, 2012 at 23:56
  • Player has options for monitor count. But it does not allows to use them due to weird autosize guest.
    – Maximus
    Feb 12, 2013 at 22:04

6 Answers 6

6

Rename or delete C:\Program Files\VMware\VMware Tools\VMWareResolutionSet.exe in the VM to prevent the resize while keeping VMWare Tools installed.

Credit goes to @Moritz Both

1
  • For anyone else who finds this in 2023 or beyond, this trick no longer works with XP and Workstation v17 / v17.5.
    – Grim
    Nov 13, 2023 at 10:50
3

If you do not want this feature, you will need to uninstall VMware tools from the Guest OS. Try this if you are not very specific about having VMware tools.

0
3

I can confirm that @BinaryMisfit is correct on how to disable this.

My setup:

  • VMware Workstation 12 Player (Non-commercial use only)
  • Windows 7 Professional (Guest OS)
  • Already set the 'Smaller - 100% (default)' radio button in the guest OS

enter image description here

I unchecked the 'Automatically adjust user interface size in the virtual machine' while the guest OS was running and after clicking 'Ok' the guest OS immediately said it needed to log out and log back in for changes to take effect.

Fixed.

3
  • In VMware Player downloaded a few days ago, "Display Scaling" option is missing even though the documentation says such an option exists. Since images cannot be added to comments, ended up adding image to answer below: May 29, 2016 at 14:22
  • Please note that this was in regard to Windows. Not Linux - which is what I see (preaumed) in the image you provided.
    – Erutan409
    May 29, 2016 at 14:28
  • 1
    This is answering a different question. This VM setting will affect DPI settings in the guest to make text and UI widgets larger or smaller. It will not enable or disable resolution changes in the guest (how many pixels wide and tall the guest desktop is).
    – jamesdlin
    Mar 12, 2023 at 8:23
2

Disabling the "Vmware SVGA II" display adapter is better than removing the vmware tools, as you keep all the other functions, the only thing you loose is Direct X/3D graphics. I'd like to know a proper solution to the problem, just out of interest you don't get this problem with windows 98 once you have set the svga.maxWidth = 800 and svga.maxHeight = 600. Why This does not work for Windows 2000/Xp etc escapes me....

1
  • 2
    Disabling the display adapter didn't help for me. Changing the VM from full screen to window still resized the windows in the guest OS (Windows 7).
    – EMP
    Jan 24, 2012 at 23:48
1

To disable the auto resize the orginal file must have the setting disabled in the Workstation edition that created the VM. By default the VM Player honors all the setting specified when creating the VM.

4
  • I've not seen this work. I have trialled VMware Workstation several times. Each time I do this, I set the "don't resize" option, but whenever I switch back to VMware Player (after the trial ends) it always reverts to re-sizing. This is the case whether the VM was created by VMware Converter, Workstation or by creating the VMX file manually.
    – Mark Booth
    Mar 30, 2010 at 11:25
  • This is incorrect. The autofit-guest option is a UI preference, not a per-VM setting. Furthermore, while VMware Player does honor some UI preferences from VMware Workstation, the autofit-guest preference is not one of them; VMware Player always enables it.
    – jamesdlin
    Mar 12, 2023 at 8:19
  • @jamesdlin Thanks for the clarification. In 2010 when this answer was supplied it was not the case. Mar 13, 2023 at 10:11
  • No, it's always been that way since VMware Player was introduced around 2003.
    – jamesdlin
    Mar 13, 2023 at 14:46
0

On VMware Player/VMware Workstation:

  1. CTRL + P (or Edit -> Preferences)
  2. Select Display section
  3. In Autofit sub-section, uncheck Autofit guest
  4. Click OK

You must log in to answer this question.