1

About a year ago, I built a new desktop computer and transferred a lot of data from my laptop's hard drive to the desktop's SSD. I did this by removing the hard drive from the laptop and using a SATA-to-USB adapter to connect it to my desktop. The laptop hasn't worked correctly since. The symptoms:

  • Hard drive is constantly pegged by various Windows services. This has several side effects, such as most icons and my desktop background taking several minutes to load, or never loading at all.
  • Explorer hangs frequently.
  • Event viewer shows hundreds of errors being generated per hour, most with either ESENT or AppReadiness for the source.
  • Chrome is unable to load my user profile.

Things I've tried:

  • SFC. No errors found.
  • DISM. Says it found errors and fixed them, but no change.
  • Startup repair from my install disk. No errors found.
  • System restore. No effect.

This leads me to believe that somehow the permissions on my file system were broken by the data transfer. The errors thrown by ESENT say that they don't have access to a file in my AppData directory, and Chrome profiles are stored in AppData as well. I also found an error from the Flash update service that said it couldn't log in to the default Administrator account because the username or password was wrong. I wouldn't be surprised if the recovery tools couldn't detect such an error. The strange thing is, I've checked the permissions on the Users and Windows directories, and they look normal.

I would just reinstall Windows, but I have a lot of software on the laptop that I was able to purchase with student discounts and won't be able to get back, since Windows 8.1 no longer has a recovery option for just fixing the Windows installation without wiping everything else. How could my file transfer have caused the problems I'm having, and how can I fix the OS without losing my software?

EDIT: I ran DISM again using my install disc as the update source per this article. This time, after it finished and told me the problems were fixed, I rebooted and Windows managed to get through installing updates. Once the updates were finished, Explorer wouldn't even run after login, even if I tried to spawn new instances from Task Manager. I did a system restore back to before the updates installed, but it didn't help. Explorer runs properly in safe mode.

EDIT 2: Per DavidPostill's request, screenshots of the SMART values for the hard drive, taken from HDDHealth: http://imgur.com/a/DTc5l

  • You're probably best off backing everything up and performing a factory restore using the manufacturer's recovery disk/partition. – Kinnectus Jul 8 '16 at 8:24
  • I'm worried that if I go that route, I'll lose access to my software anyway. Do you think it's unrecoverable? – Thomas DeSilva Jul 8 '16 at 8:50
  • Have you checked your HDD for SMART errors? – DavidPostill Jul 8 '16 at 17:23
  • @DavidPostill: SMART attributes all look pretty good. I have HDD Health installed, and it reports a 92% health rating. – Thomas DeSilva Jul 9 '16 at 3:49
  • 92% doesn't sound so good. Please edit and post the actual SMART values. p://superuser.com/questions/29240/how-can-i-read-my-hard-drives-smart-status-in-windows-7, and What is the easiest method of checking SMART status for your hard drive?. HDTune will report these. – DavidPostill Jul 9 '16 at 8:11
0

I managed to fix my laptop without reinstalling anything or replacing any hardware. It turns out that I was correct in my assumption that it was a permissions issue. Windows comes with a utility called icacls that can reset file permissions to their default values, so I wrote a small batch script to first take ownership of all files in a directory, then reset their permissions:

takeown /r /d Y /f *
icacls * /T /C /RESET

I ran this at the root of my C:\ drive and rebooted once it finished; some files had failed to be processed, but the Explorer hangs and loading failures went away.

My disk drive was still at 100% utilization from Windows Error Reporting constantly logging failures, though. Event Viewer showed that the SRUJet and SoftwareProtectionPlatform services were failing to open necessary files, so I changed the permissions on the relevant files back to the accounts that run the services by hand (these were probably the ones that failed in the previous step). The disk usage has now calmed down and errors are no longer accumulating.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.