0

I am trying this fix:

Add-AppxPackage -register "C:\Program Files\WindowsApps\Microsoft.WindowsCalculator_10.1601.49020.0_x64__8wekyb3d8bbwe\appxmanifest.xml" -DisableDevelopmentMode

But I get this error

Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF6, Package could not be registered. (Exception from HRESULT: 0x80073CF6) NOTE: For additional information, look for [ActivityId] e90d0759-d78a-0003-b82e-42e98ad7d101 in the Event Log or use the command line Get-AppxLog -ActivityID e90d0759-d78a-0003-b82e-42e98ad7d101 At line:1 char:1 + Add-AppxPackage -register "C:\Program Files\WindowsApps\Microsoft.Win ... + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : WriteError: (C:\Program File...ppxmanifest.xml:String) [Add-AppxPackage], IOException + F

ullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand

It looks like windows 10 default apps is quickly becoming a huge mess and that Microsoft never provided a tool to fix it easily. Is there any other options other than refreshing my install ?

Issue seems to be occuring after each cumulative update.

  • Doesn't happen to me, so what command have you ran, to uninstall these applications in the past? – Ramhound Jul 8 '16 at 11:50
  • I did not ran any specific command. It stopped working after a windows update. – sofsntp Jul 8 '16 at 15:27
0

See if this command-line helps..automatically registers the latest version.

Get-AppxPackage -allusers Microsoft.WindowsCalculator | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

Note that the folder name for the current version (10586.420) would be:

C:\Program Files\WindowsApps\Microsoft.WindowsCalculator_10.1605.1582.0_x64__8wekyb3d8bbwe
  • I did this and have the same error. The store doesn't work as well. Same error when trying to register it. I have the same build version. – sofsntp Jul 8 '16 at 13:49
  • I ran DISM but this did not help – sofsntp Jul 8 '16 at 14:17

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.