0

I am little bit desperate because I do not have idea what is happening. I setup network like the picture shows:

enter image description here

There is vDSL cable internet from provider. Connection is distributed to other 2 routers.

The problem is that sometimes when notebooks are connected to wifi, there is DNS problem - pages can not be loaded - chrome showing Resolving address.

However if I connect directly to router by cable, there is no problem with DNS and internet is working fine.

All router has manualy set dns to google 8.8.8.8

Do you have any advice what can cause the problem and how to solve it? Thanks

  • 1
    This is home or work environment? If this is home environment, I suggest you can plug the other routers to LAN port instead WAN port, then it become a wireless switch instead of a router, no configuration is needed, simple and easy – Bilo Jul 8 '16 at 12:25
  • 1
    What makes you think this is a DNS issue as apposed to a general connectivity issue? When the WiFi clients lose connection, can you ping 8.8.8.8? Can you ping any other external IP address? – Mark Riddell Jul 8 '16 at 12:37
  • @MarkoPolo ususally when the problem happens I can access sites like Facebook, but the problem is with loading others which I did not visit recently – Dusan Plavak Jul 8 '16 at 12:41
  • 1
    Ok, so domains which are in your DNS cache you can connect to correctly, however others which require a fresh lookup fail to connect. Try and ping 8.8.8.8 the next time this happens and see if you lose connectivity to Googles DNS servers. – Mark Riddell Jul 8 '16 at 12:45
  • Maybe add more DNS addresses? They come in pair; 8.8.4.4. – MindTooth Jul 8 '16 at 12:57
0

I'd start from ground zero - except the topmost router.

  • leave only the topmost router, all the rest turn off, make sure it works as it should with a notebook - both wi-fi and cable
  • configure the topmost router dhcp, so the ip range should start let's say at least with 192.168.0.10
  • connect a notebook to a secondary router via cable, configure it to the same subnet as the topmost router, its ip to let's say 192.168.0.2 (and ...3 at the third router)
  • as were mentioned by @Bilo, connect secondary routers via LAN instead of WAN, on secondary disable dns, dhcp, wi-fi(!) - so they become just switches.
  • connect a notebook via cable to a secondary router, make sure it works. Repeat for the third router.
  • http://192.168.0.2 and configure wi-fi on the secondary (I'd prefer the same ID/pass to enable roaming between access points), make sure it works
  • repeat for the third router using its ip.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.