3

I use a wattmeter to measure the power-consumptions of my computers. The following is the result:

my laptop     + Ubuntu 14.04:              14.5 watt
my laptop     + ArchLinux:                 30 watt
my laptop     + Bios Setting:              45 watt
my laptop + Ubuntu 14.04(init=/bin/bash):  31 watt
my laptop + ArchLinux(init=/usr/bin/bash): 33 watt
my old laptop + Ubuntu 14.04:              21 watt
my old laptop + Ubuntu 16.04:              24 watt
my old laptop + ArchLinux:                 19 watt
my old laptop + Bios Setting:              22 watt

PS:
my laptop(CPU: i5-2410; BIOS: AMI A0.18; Board: TSINGHUA TONGFANG CO.,LTD)
my old laptop(CPU: Pentium Dual-core cpu T4200; Board: LENOVO; Board: LENOVO)

all the data except when it is in Bios Setting modes are collected while the environments are idle waiting for user commands and the CPU rate is very low.

I want to tune my ArchLinux use the same or even less power than Ubuntu-14.04. I have tried cpufreq, phc-intel, and compiled my own linux kernel but nothing worked. I tried to run powertop --auto-tune, and both ArchLinux and Ubuntu-14.04 reduce power consumption by about 2-3 watt.

Here is the boot message related to ASPM of my laptop:

> dmesg | grep -i aspm
[    0.162661] acpi PNP0A08:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI]
[    0.162746] acpi PNP0A08:00: _OSC failed (AE_ERROR); disabling ASPM
[    3.323580] r8169 0000:04:00.0: can't disable ASPM; OS doesn't have ASPM control

It's strange to note that my laptop in bios setting mode consumes 45watt. And there must be something to do with user space services, since both Ubuntu-14.04 and ArchLinux consume about 30 watt when they are init to /bin/bash. Could you explain why it's so high? Thank you.

  • The BIOS mode probably doesn't run many of the actual fan control or multiplier adjustment (that is, keeps the CPU running at full speed even if idle). – Paul Stelian Jul 8 '16 at 13:18
  • 1
    yes, I thing so. My laptop CPU has pstate support, and the Linux kernel use this feature to lower CPU frequency. – TorosFanny Jul 8 '16 at 13:30
  • 2
    On one of my old computer the graphic card was with the clock at its maximum (and its fan too) during the BIOS checks and until Ubuntu was completely up. On some BIOS it is possible to set it up. Not all BIOS decrease the power of the CPU when not used. Did you load the same drivers and services on the two Linux distribution? Maybe some indexing service is running in the background... – Hastur Jul 8 '16 at 13:44
  • 1
    In addition to Hastur comment, you can use powertop to tune hardware power save options and monitor use of hardware to compare between distributions. – user.dz Jul 8 '16 at 15:30
  • 1
    @Hastur, you are right. I tried to run ArchLinux and Ubuntu-14.04 with kernel parameter init=../bash, and their power consumption are nearly the same. I have to figure out which user space service in Ubuntu-14.04 lowers the power consumption so significant. – TorosFanny Jul 9 '16 at 14:09
1

I successfully reduce my laptop's power consumption to about 16.7watt.

The key is install bbswitch, according to https://wiki.archlinux.org/index.php/Bumblebee#Power_management.

|improve this answer|||||
  • ... if you have 2 graphics cards (one nvidia). – Francesco Nov 27 '16 at 5:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.