4

I have a question about port forwarding with FRITZ!Box.

When I port forward for my server, it works for a while, but after 3/4 days people can't join my server anymore. It's really weird and I have to port forward again.

I had the same problem today, but this time, the port forward didn't work anymore. I did the same thing as before as far as I know.

Could someone explain what is wrong?

enter image description here

enter image description here

3
  • John the 1st picture link is missing, could you edit question and add it?
    – user.dz
    Jul 8 '16 at 15:18
  • You don't have to black out local LAN IPs. Noone is able to do anything bad with them. But either way this looks fine to me. Have you checked whether your FIrewall blocks incoming connections for the Minecraft server?
    – Mario
    Jul 8 '16 at 15:24
  • What's your fritz!box model number and do you know the firmware version it's running? Quick Thoughts: 1. Perhaps you need to update the firmware and do a power cycle of the device due to memory fragmentation. 2. If you still have issues you may consider factory resetting the device and then seeing how it works after a firmware update if applicable. 3. Lastly, you could run a Wireshark trace when it does and when it does not work and compare to see if anything there gives further clue at that level. Jul 8 '16 at 16:01
5

I had similar problems with my Fritz 7490. In my findings, it's related not to the port forwarding itself, but the Fritz notion and behaviour of the destination machine ("to computer" field in your screenshot).

Example: If the same machine (one MAC address) boots up different operating systems/hostnames, Fritz gets confused, and that affects port forwarding. Also if you use the "specific IP address" the port forwarding configuration, but then later change/add a machine config with the same IP address, the port forwarding changes to point to that machine "name" instead of the IP.

In summary: try to clean up the machine/MAC list in Fritz (in "Home Network > Home Network Overview > Network Connections"), making sure there's no conflicts, and re-create the forwarding rules. That should fix it.

1
  • This is still relevant 😕 I'm using a dual-boot-system (Windows and macOS) and it keeps forgetting the rules if I change the OS (not always; but ~every second reboot)... Jul 30 '19 at 0:50
0

Its more related to powerloss. Loss of power somehow causes port forwarding rules to get deleted. Not always but only sometimes.

0

In case you landed on this page because you can't reach a server running inside a Xen Guest from the internet (but can connect locally), then read on...

  1. The fritzbox can get confused by different OS'es appearing from the same MAC-address etc. (could happen while you are setting up / experimenting with Xen)
  2. The fritzbox has seemingly duplicate entries in the list, but with different settings, you need to delete the portmap from the incorrect entry, cleanup the list and reapply the portmap settings.
  3. It might be that your guest OS has no default gateway IP-address set. You'd expect a default gateway set to the local IP-address of your fritzbox.

The symptoms of a missing default gateway is that your LAN PCs can access the server running inside the guest just fine, but external users from the internet cannot connect.

0

Issue for us was, that we had the setting to forward a singe port 26900 as opposed to a range 26900-26902. The server was showing in to lobby but connection failed through the internet. Changing the forwarding to a range fixed the issue.

0

I had the same problem. I could only fix it thru a factory reset. Somehow i think the cache of the connections list gets corrupt and doesnt represent the list in the ui.

0

My issue was that I thought it was due to this router, but realised that my service provider also had a firewall. Silly me.

0

I find that the fritzbox just randomly replaces the ipv6 suffix which I set. That might be happening , and if that is so, then the externals will not get forwarded to your home network host but to the random address that the fritzbox sends them to. very frustrating for email.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.