I am using a Mac OSX, updated my bash_profile after following the instructions in one of the Udacity courses. However I am no longer able to access to my ipython notebook or even conda. I get the following

conda --version 
-bash: conda: command not found


ipython nootebook 
-bash: ipythone: command not found

I am not sure how to fix this. I tryied erasing my .bash_profile file but it does not work. I also tried the suggestion here did not work and this one did not work either. I have also noticed that my the title in my terminal has and extra - . It reads carlosdelamora-- -bash--80x24 and I believe it used to be carlosdelamora--bash--80x24. I do not know if that is relevant.

  • I should say that I did not updated my .bash_profile file but I created one. I also have a .bash_profile-anaconda.bak, .bash_profile.pysave in my home directory. – Carlos De la Mora Jul 8 '16 at 20:08
  • Assuming default anaconda installation path, you just need to add this line to .bash_profile export PATH=$HOME/anaconda/bin:$PATH – Argonauts Jul 8 '16 at 22:07

I would think that you have lost the PATH command added by Anaconda.

Add this to your .bash_profile

export PATH="/Users/<username>/anaconda/bin:$PATH"

(Replacing <username> with your username, of course.)

  • It now has conda working. At least when I type conda --version I found it. However it still not working the way it used to be. I have two other files .bash_profile-anaconda.bak .bash_profile.pysave – Carlos De la Mora Jul 11 '16 at 3:25
  • Ok I added .bash_profile-anaconda.bak and it works as it used to. – Carlos De la Mora Jul 11 '16 at 3:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.