1

I have recently acquired a WRTP54G Linksys Router that I would like to use. Yes, I know it is obsolete, and no, I do not intend to use it as my primary router. I have connected the router to my current main router.

The Linksys router has been assigned the local IP address of 192.168.1.114, and I am trying to connect to it in my web browser to configure it via the web interface. The problem that I am having, as shown by pinging the IP address, is that the web interface is only accessible for several seconds after the router is reset. After that, the web interface becomes inaccessible, I am unable to access it again without resetting the router again. Even a power cycle does not make it available for several seconds.

What exactly is the matter with it, and how can I fix it?

  • Are you accessing it on the 192.168.1.114 address your current router is giving it? You have a line going from your existing network's LAN to what port on the WRTP54G? Have you tried just connecting to the LAN port of the WRTP54G after a reset, without having it plugged into any other networks? – MagnaVis Jul 11 '16 at 1:52
  • @MagnaVis Yes, that IP address was assigned to it by the current router. The port that it is going to on the router is labeled "Internet". I have not tried connecting it to any of the other ports. – DaveTheMinion Jul 11 '16 at 1:59
  • perfect, then my answer should help get you on track. – MagnaVis Jul 11 '16 at 2:00
3

It sounds to me like you're trying to access the WAN port of the router. Plug into one of the LAN ports, and disconnect it from your other network (there will likely be overlap on the 192.168.1.0/24 network, and the less confuision the better). I just looked at a picture of your device, and the ports on the LAN side are labeled "Ethernet." Any one of those is where you want to be.

My guess is that it becomes inaccessible and stays that way because the WAN Firewall sets up and runs by default going forward.

UPDATE: The first part is still necessary, but it sounds like there could be image corruption. I would try flashing a new firmware to the router before it crashes, or hope that SSH or Telnet don't crash with the Web Server of the router. Here are some ways to flash a new firmware: https://wiki.openwrt.org/toh/linksys/rtp300#firmware_flashing

It does look like the router supports TFTP flashing, so if you can make it available for a short amount of time, that would be the best method of reflashing it. using the TFTP method prevents the router from booting, instead the bootloader prevents handing off to the OS, and writes a new image over the existing one. This is probably your best bet for getting it up and going again. Depending on how old it is, there is a chance the flash where the firmware lives is bad. Bear that in mind if you continue to run into problems.

|improve this answer|||||
  • I am sorry, as I do not quite understand what you are saying. Are you suggesting that I try plugging the router directly in to my computer? – DaveTheMinion Jul 11 '16 at 1:55
  • Yes. You cannot connect to the WAN interface, and it sounds like that's what you're trying to do. I'm not 100%, but if that's what you're trying, it won't work. I would take a cable and plug your computer directly into one of the LAN ports of the WRTP54G. Your computer should get an IP from the WRTP54G, and odds are it's IP will be 192.168.1.1 – MagnaVis Jul 11 '16 at 1:58
  • Thanks! It worked, although the IP is 192.168.15.1. Any idea why? – DaveTheMinion Jul 11 '16 at 2:03
  • Umm. It looked like it worked, but it seems that I am still having the problem. It dropped off again. I tried resetting it just now, and now the ethernet seems dead. – DaveTheMinion Jul 11 '16 at 2:07
  • This is a SMB router, so it likely came with some kind of VPN built in, and Linksys wanted to avoid having the LAN overlap with the networks of the home users. Glad it worked for you! – MagnaVis Jul 11 '16 at 2:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.