in April this year I bought a new Samsung SSD 750 EVO 250GB, installed it on my desktop pc and made a fresh installation of Windows 10. However, since I got this SSD, Windows will randomly lock up on some occassions. I can still move my mouse cursor while it is locked up, but if I click on something nothing happens. When Windows finally decides to unfreeze after about 15 seconds up to several minutes, all my previous actions get executed.
About last week, when I looked into the event viewer of Windows for the first time since I installed it, I noticed that it is full of events with ID 153 (from one every few minutes to several per minute), which state that an I/O operation had to be retried on my SSD. As the block address changes from every event to another, I'm pretty sure that it isn't a failing block. From time to time I can also find events with ID 129, which state that it had to reset my SSD.
Doing some more research (as described in this article), I found out that the warnings only occur while writing onto the SSD as the last bytes in the details for each event 153 that I've checked are 00 (SCSISTAT_GOOD), 04 (SRB_STATUS_ERROR) and 2A (SCSIOP_WRITE). I also found out that the average response time (according to the task manager) of my SSD can be as high as 20 seconds (not milliseconds) while writing onto it, though it's mostly at about 500 milliseconds while writing. If I'm just reading from it, everything is normal (average response time of about 0.1 to 0.2 milliseconds).

What I've done so far (however none of the following has neither helped to resolve the problem nor given me some more information of what to do):

  • I switched the SATA cable, SATA port on my mainboard (ASUS M5A97 LE R2.0) and the SATA power plug.
  • I checked SMART status of my SSD (results can be viewed here). Except for the CRC error count everything looks fine to me.
  • I started several SMART self tests. Most of them stopped with "Interrupted (host reset)". The one test that did complete didn't find any errors.
  • I ran chkdsk. No errors were found.
  • I ran an error check with HD Tune to search for any defective sectors. Nothing was found.
  • CrystalDiskInfo also reported that my SSD was fine.
  • I installed Samsung Magician to check for new firmware, but the SSD already has the newest firmware installed.
  • As I already had Magician installed, I let it run a performance benchmark. It only finished the sequencial read with a result of 522 MB/s. While testing sequencial writing speed it interrupted the benchmark and said that it got a timeout.
  • I tested performance of the SSD with AS SSD Benchmark to see if it would also give an error while testing sequencial write speed. And it did. It does finish the 4K benchmark with a result of 34.20 MB/s for reading and 5.02 MB/s for writing (which seems to be very low).
  • I checked for newer SATA drivers, since the driver that is currently installed is from 2006. Windows didn't find any newer driver nor did I as I looked at the official downloads page from ASUS.
  • I checked, if AHCI and TRIM are active for my SSD, which both of them already are.
  • I changed AHCI power link management from "HIPM + DIPM" to "active" and told Windows to never shut down neither my hard drive nor my SSD.

Right now I'm totally out of ideas what I could try next to resolve the problem I'm experiencing.
Could a BIOS update help? (Though I'm pretty sure that this wouldn't solve the problem either)
Did I just get a faulty SSD and should therefore send it in for an RMA?

Thanks in advance for any help.

  • Have you found any solution? I was using Symsung SSD 840 under Linux for an year or more, then I bought new drive and "downgraded" this one for Windows installation. Same issues, many of these 153 events, slow and lagging PC, very slow booting times. Terrible. – lzap Oct 4 '17 at 18:37
  • @Izap As it turned out, the problem seemed to be caused by my BIOS version being very old. In fact so old that it caused problems with SATA SSDs. Maybe a BIOS update can help in your case as well as it helped me. – Fabian B. Oct 5 '17 at 19:15
  • You're doing several smart checks. Keep it up and it looks like you'll be able to get this problem resolved. If it is a hardware issue, which looks entirely possible, sometimes the only way to determine which piece of hardware has failed is to successfully try swapping that piece of hardware. If your SSD is bad, I won't be able to tell you when it went bad, so I can't tell you whether it was bad at the time you purchased it. If you find that is bad, check your warranty. (Keep in mind that if you do a warranty swap, you're potentially giving away a copy of your data.) – TOOGAM Oct 6 '17 at 11:13
  • FInally solved, it was a loose SATA cable connection! As easy as that. See my answer below. Thanks. – lzap Oct 10 '17 at 14:35

Just dealt with the same issues on a PNY SSD on a clean install of Win 10. Issue can be triggered by putting the system to sleep, waking up & immediately trying to access the HDD by opening a folder or file. Event ID 153 & 129 appear in the event logs after a 10-30 sec freeze of the OS.

Another forum suggested using standard SATA drivers instead of the AMD ones I downloaded from Gigabyte. When I went to roll back, I actually found that the SATA controller was using the "Standard SATA AHCI Controller" driver from Microsoft (version 10.0.10586.0, 6/21/2006). I updated the driver using the "Browse my computer for driver software" option, and browsed to the location of the unzipped chip set package. It found & updated the driver with one from AMD (v 1.2.1.402, 3/29/2015) After reboot, issue is resolved.

While this doesn't match your conditions exactly, it should point you towards the 2006 driver from Microsoft as being the most likely source of the problem.

Since you can't find an official Win 10 driver from ASUS, I'd recommend using Snappy Driver Installer to check for a new one (https://sdi-tool.org/) . This a free, no B.S. tool that will search for updated drivers for your chip set that were released by other manufacturers. I've found it useful many times when I can't find an official driver for something.

  • Hi Paul, thank you for your answer. While updating the drivers using Snappy Driver Installer alone didn't help, it did resolve my problems in combination with a BIOS update. Now the event viewer doesn't show any new Event ID 153 & 129. However, it looks like the problem isn't solved completely, since I get the advertised performance for sequencial reading and writing (about 500 MB/s for both), but not for 4k reading (33.08 MB/s) and writing (62.03 MB/s). – Fabian B. Jul 24 '16 at 7:26

Not sure if this is helpful, but I had bad SATA cable or loose SATA cable connection. My drive is Samsung SSD 840 and apparently its SATA port does not have the holes so cables will not "clip" therefore it can easily loose when you are working in the case and touching cables.

I was experiencing many of these event errors (thousands per day), PC was lagging a lot. Samsung Magician benchmark showed poor 76 MB/s read performance.

I replaced the cable, made sure it is connected properly (yeah DUCK TAPE I am looking at you!) and everything is so smooth, no more 153 events anymore and benchmark went up in reading to 540 MB/s. This is not the first time I experienced loose SATA data cable, this port design has a serious issue.

I also had another symptom - when booting Windows 10 in EFI mode, I was getting random "corrupt winload.efi" error. I only booted few times, but the error is now gone and boot is much faster. So I believe I fixed both issues at once (slow boot with random blue-screen error, event 153).

I had a similar issue. I was about to go crazy. I discovered that a sata cable, though it has a locking mechanism, was somehow cocked to one side ever so slightly. I reseated all sata cables and voila, no more Event 153's and quick boot. It was reduced form 2 minuses to 25 seconds.

For my Dell Inspirion laptop, that had been upgraded to Win 10 with a G-skill 240gb ssd, was able to solve this by

I. replacing the 2006 microsoft SATA ACPI controller , with an Intel 7 series chipset family SATA AHCI Controller, as recommended on the dell website.

II. In control panel power options, I chose changes settings for the plan selected, then chose reset the balanced power option to the default. Then chose Advance Power options. And under Hard Disk , turn off hard disk , entered 'Never' under plugged in.

Note: I use my laptop plugged in 95% of the time. You can also increase the On Battery setting.

I am wondering if I could have just done II.. but I had already done I.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.