3

I have Windows 8.1 on computers which remains online 24 hours. The systems reboots every night once (scheduled task: shutdown.exe -r -t 00). The device goes to lock screen some times. Mostly in night time. When I check it in morning some devices are on lock screen. I have disabled the lock screen in:

  1. gpedit.msc by enabling the "Do not display the lock screen" in Administrative template > control panel > personalization
  2. Disabling same above setting in regedit
  3. Set "Not require password on wakeup" in control panel > power options
  4. Disabled all sleep mode transition in control panel and gpedit.

Still the device goes to lock screen, but not always.

  • 2
    Does the device log out existing users? Please check system log of the machines known to go into lock screen to check if anything unusual happened, such as a power outage, etc. – Jack White Jul 19 '16 at 15:44
  • Yes the device log out from existing user. – Gaurav Jul 20 '16 at 8:07
  • I think I found it by looking into "logoff" event in event viewer. Earlier i was checking for "lock" event. I can see an event 7002 (User Logoff Notification for Customer Experience Improvement Program) on those days. It might be the problem. I am going to disable this and check. – Gaurav Jul 20 '16 at 9:10
  • I was wrong :( Event 7002 are also there on the dates when device was not locked. – Gaurav Jul 20 '16 at 12:59
3
+50

Gaurav commented:

I think I found it by looking into "logoff" event in event viewer. Earlier i was checking for "lock" event. I can see an event 7002 (User Logoff Notification for Customer Experience Improvement Program) on those days. It might be the problem. I am going to disable this and check

I was wrong :( Event 7002 are also there on the dates when device was not locked

.

You were probably not wrong. This appears to be the work of infamous CEIP. It is entirely possible that it causes logouts incosistently.

Even if it is not the cause this time, please disable it just to be sure - it has no benefits being enabled.

Although it would be logical that either one of steps below should be enough disable CEIP, please be sure to do all of them - it is known that doing just one is not enough.

1. Group policy

  • Open Group Policy Management Console by running gpmc.msc, and then edit an appropriate Group Policy object (GPO).

  • Expand Computer Configuration, expand Administrative Templates, expand System, expand Internet Communication Management, and then click Internet Communication settings.

  • In the details pane, double-click Turn off Windows Customer Experience Improvement Program, and then click Enabled

Note: There is no typo here, you need to ENABLE the setting that turns OFF the CEIP

  • If the computer is in a domain, make sure that all relevant domain controllers also have a policy to disable CEIP, otherwise your setting will be overridden and won't take effect

2. Control panel

  • Open the control panel and click Action Center > Change Action Center settings.

  • Click Customer Experience Improvement Program settings.

  • Select No, I don't want to participate in the program and click Save changes.

3. Task scheduler

  • Start the control panel and click Administrative Tools > Task Scheduler

  • In the Task Scheduler (Local) pane of the Task Scheduler dialog box, expand the Task Scheduler Library > Microsoft > Windows nodes and open the Application Experience folder

    • Disable AITAgent and ProgramDataUpdater tasks
  • In the Task Scheduler Library > Microsoft > Windows node, open the Customer Experience Improvement Program folder

    • Disable all tasks in this category, in my case they were: Consolidator, KernelCEIPTask, and USB CEIP
  • In the Task Scheduler Library > Microsoft > Windows node, open the DiskDiagnostic folder.

    • Disable the Disk Diagnostic Data Collector task.

4. Registry

  • Run regedit.exe

  • Navigate to: HKEY_LOCAL_MACHINE\Software\Microsoft\SQMClient\Windows

  • In the right pane find a line named CEIPEnable and set it to 0

    • If it is not there, first create it of type REG_DWORD
  • If this setting keeps resetting to 1 after rebooting, recheck local and domain group policies (step 1)

5. Reboot

  • Make sure to reboot the computer and you should be done.

If, after all above is done, some computers still logoff/reboot please recheck the logs. If, despite doing everything above, event 7002 still appears then you may be out of luck - there are unresolved complaints just like yours.

Please comment if it helped or if it did not. There may be additional steps required to troubleshoot.

1

Try the settings for the screen saver, i think there is a option "require login after timeout" or something like that.

  • 1
    Screen saver is disabled. – Gaurav Jul 15 '16 at 11:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.