I long used Cygwin 64bit and cygwin's package All/Net/stunnel: Universal TLS wrapper on my Windows 10 machine very happily.

Suddenly however, STunnel doesn't respond anymore. I know it's very vague, so I'll provide some info below. I have installed version 5.31-1, but also tried with 5.28-1 to no avail.

$ # from the man page for stunnel, 
$ # -version should output version and compile time. 
$ # But nothing comes out. 
$ stunnel -version
$ stunnel -help
$ type stunnel
stunnel is hashed (/usr/bin/stunnel)
$ which stunnel

The lack of output is driving me crazy, not sure why nothing comes out. I completely uninstalled cygwin - following the website guidelines - then reinstalled cygwin and stunnel.

I suspect a missing library, but cygwin takes care of all dependancies, unless it's not and I really miss an important library. I have installed perl and openssh but still no luck.

$ cygcheck ../../bin/stunnel.exe

$ ldd ../../bin/stunnel.exe
    ntdll.dll => /cygdrive/c/WINDOWS/SYSTEM32/ntdll.dll (0x7ffbd65b0000)
    KERNEL32.DLL => /cygdrive/c/WINDOWS/system32/KERNEL32.DLL (0x7ffbd5890000)
    KERNELBASE.dll => /cygdrive/c/WINDOWS/system32/KERNELBASE.dll (0x7ffbd2f90000)
    TmUmEvt64.dll => /cygdrive/c/WINDOWS/system32/tmumh/20019/AddOn/ (0x7ffbd0350000)
    PSAPI.DLL => /cygdrive/c/WINDOWS/system32/PSAPI.DLL (0x7ffbd39a0000)
    SHLWAPI.dll => /cygdrive/c/WINDOWS/system32/SHLWAPI.dll (0x7ffbd3d10000)
    msvcrt.dll => /cygdrive/c/WINDOWS/system32/msvcrt.dll (0x7ffbd5a50000)
    combase.dll => /cygdrive/c/WINDOWS/system32/combase.dll (0x7ffbd6200000)
    RPCRT4.dll => /cygdrive/c/WINDOWS/system32/RPCRT4.dll (0x7ffbd6490000)
    bcryptPrimitives.dll => /cygdrive/c/WINDOWS/system32/bcryptPrimitives.dll (0x7ffbd2e70000)
    GDI32.dll => /cygdrive/c/WINDOWS/system32/GDI32.dll (0x7ffbd3a20000)
    USER32.dll => /cygdrive/c/WINDOWS/system32/USER32.dll (0x7ffbd3db0000)
    ADVAPI32.dll => /cygdrive/c/WINDOWS/system32/ADVAPI32.dll (0x7ffbd3f10000)
    sechost.dll => /cygdrive/c/WINDOWS/system32/sechost.dll (0x7ffbd5520000)
    IMM32.DLL => /cygdrive/c/WINDOWS/system32/IMM32.DLL (0x7ffbd3d70000)
    tmmon64.dll => /cygdrive/c/WINDOWS/system32/tmumh/20019/TmMon/ (0x6fa30000)

How should I go about troubleshooting this problem? I tried on a colleague's pc and he has the same problem.

  • don't use ldd, it will not report missing dlls. Use instead cygcheck – matzeri Jul 12 '16 at 15:08
  • @matzeri done. so it looks that no library is missing.. – fabiog Jul 12 '16 at 15:44

As cygcheck says that all dll's are in place, you can use two ways to highlight a mismatch in library

You can use

http://www.dependencywalker.com/ or run

strace -o tunnel.strace stunnel
  • $ stunnel -version $ strace -o tunnel.strace ../../bin/stunnel.exe Segmentation fault $ stunnel -version – fabiog Jul 12 '16 at 16:44
  • look on the tunnel.strace for hints – matzeri Jul 12 '16 at 16:45
  • file is empty :-( – fabiog Jul 12 '16 at 16:47
  • strace -o tunnel.strace stunnel.exe . Without "../../bin/" – matzeri Jul 12 '16 at 16:49
  • I will bet on an AV interfering on stunnel running – matzeri Jul 12 '16 at 16:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.