4

I've recently installed a dev-channel Chrome 53 (currently the latest, Version 53.0.2785.8 dev-m (64-bit)) and noticed that Chrome now renders in-page fonts ignoring MacType, and I wouldn't say I like it much (it all depends on fonts: some fonts look good, some fonts are very thin being very "faded", but in general the font geometry is correct and the fonts do not look distorted).

There is a manual on Reddit that helped me last year, but according to this post, the DirectWrite disabling option has been removed in the beta/dev versions and will be removed in public versions soon. However, I still can use the --disable-directwrite-for-ui command line argument to enable MacType for UI elements (and it really works cool), but even this command line option seems not be documented but experimental, and probably will be removed as well. I really don't like these changes since I've been fighting some older Chrome versions to enable MacType and make the text easier to read, but now it seems MacType will not work with Chrome in the future.

Is there any way to make Chrome MacType-friendly again? Any comments or answers are greatly appreciated!


Edit 1:

My Chrome has been recently updated to 54.0.2816.0 dev-m (64-bit), and now even the urlbar looks non-MacType-d unfortunately. I really hate ClearType since none of Windows fonts looks fine to me when ClearType is enabled, so I just use MacType as much as possible. Unfortunately not the time for Chrome...


Edit 2:

For those who might be interested in an alternative: https://github.com/snowie2000/mactype/issues/197#issuecomment-253343953 - MacType seems to be able to work in Cent. I couldn't manage it work, however, MacType works with Firefox perfectly. I wish it could work in Chrome again. (:

0

Follow link and download latest MacType Patch

Then you should disable native GDI hooking via MacType for Google Chrome. MacType Patch will make use DirectWrite instead of GDI.

If you using MacType Registry-mode, then be aware that font smoothing will not working for the raw application run. You need to activate MacType Process manager and make sure, than in-run DirectWrite Application is "ignored" checked. In that case all will be fine.

Have a good Day!

0

Just wanted to weigh in to say that I got something working by using a Stylish script. The Mactype Patch solution wasn't working for me, so I tried something different. You can access it here: https://userstyles.org/styles/134233/beautify-fonts. It's fit to my liking (I like big fonts to avoid distractions, and I have a thing for the Corbel typeface) but you're free to edit everything once the script is installed.

The UI won't be transformed, but you can use --disable-directwrite-for-ui to launch Chrome, provided that you did not use the MacType Patch.

  • I created a similar Stylish stylesheet with a single text-shadow property earlier, but I couldn't make myself to use it -- the fonts looked too blurry and I would say, a sort of, unnatural to me. Thanks for the stylesheet anyway, I do believe many people will install it. ;) – Lyubomyr Shaydariv Oct 24 '16 at 18:57

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.