0

I have tried several tricks and none of them are working i have tellephone numbers '+4 55 555 555 555 and in excell the cells that have the little green triangle warining sign, they loose the +4 and then have no +4 just a number when exported to csv. I am exporting to csv uni-code 8.

I have tried - formatting to text -formatting to text 0000000000000 thing that some one said - closing and opening excel and then changing file to .txt, then opening file through Open and chosing options for "text" for the number fields

ideas?

  • In "Format Cells" dialog, choose "Custom" and type +4 00 000 000. +4 would be prefixed automatically for that cell. – Win32Guy Jul 12 '16 at 16:31
  • And if i have multiple beginnings +4 +1 +27? and multiple lengths? – Faste Jul 12 '16 at 16:36
  • Another way is to type the complete phone numbers in column A without the plus symbol, and display them with + symbol in Column B. Example: in B1 type ="+"&A1 – Win32Guy Jul 12 '16 at 16:48
  • And, formatting the cells/column as text works fine here, with a warning of course, which can be ignored. – Win32Guy Jul 12 '16 at 16:55
  • hmm.. I have a doc with 4000 rows with tel no in two columns, and I need to get it out ;/ not type it in – Faste Jul 12 '16 at 17:23
0

Go to FORMAT + CELLS + SPECIAL + TELPHONE NUMBER.

Or type a space before the phone number if set as text. I think that works.

Hope this helps

  • "FORMAT + CELLS + SPECIAL + TELPHONE NUMBER" sorry dont follow that at all. – Faste Jul 12 '16 at 20:21
  • Sorry don't follow this forum that much. Here is a more detailed explanation, if it is not too late. Select the column, then right click, select FORMAT CELLS, Under the Tab called NUMBER, select SPECIAL, you will see the option to select TELEPHONE NUMBER. My bad I assumed that you were at that section before. – Richard Aug 4 '16 at 2:52
0

Thanks ALL for help! but I did try a lot of tricks to try resolve, too many cells were differently formatted, some had plus some did not. How I resolved this was I used LibraOffice. Its free and it just worked out the box and left my numbers to be right. Was actually better as it just bypassed everything and made sure each time I saved I was really getting Uni-code 08, which is what I needed to import in Wordpress. I also tried Google sheets, but it crashed as my sheet was very large. Did test numbers and it also muddled them up.

The only Issue Libra gave me was I had to make a new date format, which was easy to do.

Thanks a mill for all the efforts!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.