4

I want to activate a microphone on my machine via the command line. I use amixer for this.

amixer set "Front Mic" 66%
amixer set "Digital" 100%
amixer set "Front Mic Boost" 100%
amixer set "Capture" 100%

This set the volume settings. The problem is that capture is deactivated. Amixer displays this output:

Simple mixer control 'Capture',0 Capabilities: cvolume cswitch Capture channels: Front Left - Front Right Limits: Capture 0 - 54 Front Left: Capture 27 [50%] [-18.00dB] [off] Front Right: Capture 27 [50%] [-18.00dB] [off]

I can active capture via kmix after that amixer shows the channels as on. But the man pages don't show how to activate the channels via amixer.

7

Capture is activated via the following command:

amixer set "Capture" cap 
1
  • Brilliant. I didn't know that capture mode could be "off", although there is no visible indicator in alsamixer. In my case, a Cmedia 6206 based card, apart from setting PCM Capture Source (which can be done in alsamixer), I had to additionally "enable" the Line input (a dedicated control), using amixer -c1 set Line cap. – 0__ May 29 '20 at 10:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.