2

I was able to connect to my centos server using ssh (PuTTy) normally. After I changed the root password of the VPS through my host's control panel I haven't been able to connect to my server via SSH anymore. Every time I try I get the "connection timed out" error. After I changed the password the websites in that server went down as well.

I checked if I could connect to another of my VPS servers (different host). I was able to connect to it normally. Just to try, I changed the root password of that second server through the host's control panel, same happened. I can no longer connect to my second server through SSH. "Connection timed out" error there too.

I'm still able to connect to other servers, just not those two ones I changed the root password to. I checked if my port 22 was working fine (which it is).

The support people from the host providers say the servers are working fine. A friend of mine tried connecting to my first server through puTTy and it worked, he even accesses as root.

Any ideas? This is maddening. I can connect to other servers just not those two, but they work for other people.

Changing the root password shouldn't create this kind of problem, should it? What is even stranger is that it took down all websites hosted on the first server.

Any help would be appreciated!

Edit 1: my PuTTY version is 0.66. Tried using the latest development snapshot just in case, same happens. Cleared putty's cache, same happens. Randomized my server's SSH access port, same happens. Still unable to connect from my computer.

I'm now checking if it could be my IP is blacklisted for some weird reason.

Edit 2: I'm able to access the server through the SSH console offered by the host service, but again, not through normal methods...

  • Does your putty saves the passwords somehow? Do you have links for each putty connection to the server of the kind "C:\Program Files\PuTTY\putty.exe" user@server.com -pw password. ? Ps> Welcome on SuperUser, please edit your post adding the version of putty you are using. – Hastur Jul 12 '16 at 17:28
  • Thanks for the welcome Hastur! My version is 0.66. I tried using the latest development snapshot just in case. I just cleared PuTTY's cache and the same still happens. I randomized my SSH access port to see if that helped, still nothing... original post edited. – Obed Marquez Parlapiano Jul 12 '16 at 18:41
  • You're welcome. Sorry only questions no answers: are you able to ping the server? to traceroute it? It seems you are not any more in the same VP N (is it needed to connect through ssh? Are you sure you didn't change the authorizations too from that panel?). Good Luck. – Hastur Jul 12 '16 at 18:48
  • No problem, any questions are welcome, I ran out of things to try. I tried pinging the server from my end and it came as if it was down, 0 packages. It looks like my PC is unable to reach the server, but I checked from an online service and it pinged the server OK, it is up and running. Another thing: I was able to access the server through the SSH console offered by the hosting company, but that's not exactly a fix :( – Obed Marquez Parlapiano Jul 12 '16 at 18:52
  • Did you need to be in the same VP N (Network) when you connect through ssh? If yes check if you are in the same subnet. (Sorry but I've to go let me know) – Hastur Jul 12 '16 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.