2

I'm speeding up a video by 2x with this command:

ffmpeg -i input.mp4 -r 50 -vcodec mpeg4 -filter:v "setpts=0.5*PTS" -filter:a "atempo=2" output.mp4

However, the output quality is very low. I used -r 50 because that's what the Ffmpeg guide recommends (here) in order to avoid frame dropping. What can I do to keep a good quality in the output?

3

Unless specified, FFmpeg defaults to a video bitrate of 200k for codec mpeg4. So, just override it with a higher value.

ffmpeg -i in.mp4 -vf "setpts=0.5*PTS" -r 50 -c:v mpeg4 -b:v 1500k -af "atempo=2" out.mp4

You may want to skip the r option if the content doesn't have very fine motion. You'll achieve better quality at the same bitrate.

1
  • 1
    I did it without the r option and the result is perfect! Thanks! – rubik Jul 13 '16 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.