2

I have this small Sata HDD and I bought an enclosure for it, the asmedia as2105 usb device. Now, my computer does detect the enclosure, but not the disk in it. I've tried other disks too, but no joy. At the moment, I've no other means of testing these disks in other ways like a desktop.

I would format this hdd, except, I can't because the disk is invisible.

How can I fix this? so I can see the disk and format it. And use it.

Device Manager Disk Management I've checked out the similar questions, but I've done all that but still no luck

External HDD not detected

External hard disk can be detected but cannot be accessed

Also, there were no real solutions to these questions there, at least none that I could see.

So, what's really annoying is that apparently the computer sees the drive in Device Manager, Disk Management and via DISKPART, but not via Windows Explorer. To be precise: the computer does see the enclosure, but not the HDD.

  • = I let windows look for updates to the drivers for the enclosure. I also found stand alone drivers for it, but I don't know if I should use those, viruses etc. It has some virus: virustotal . com/en/file/2097cfcef072f6b12370139d94a171073df2255807c01ad6d747f0d24a190aa6/analysis/

  • = I tried adding a device via windows 10 itself, but again, no joy.

I've now read this one too: Hard drive (SATA) making trouble when connecting via USB

it sounds similar to my problem, and yes, I suspect diskdeath too but it seems unlikely.

5
  • Is the drive connected completely inside the enclosure? I've had enclosures that had a bit of wiggle room and the drive slipped outta the connectors. – Michael Frank Jul 12 '16 at 23:29
  • is this the drive you took out of your Cisco recorder? If so, that would have been useful information, as well as a linking those questions... – Keltari Jul 12 '16 at 23:32
  • Yes, it's almost as if the drive not connected completely inside the enclosure, but I've looked and looked and there is no physical better way of connecting it. It's almost as if it needs a jumper on the drive itself to switch it on, except I thought SATA drives don't use jumpers === Yes it's the Cisco drive, imho, that's not all that relevant, but sure, now you know. – GwenKillerby Jul 13 '16 at 0:21
  • Show us a screenshot of Disk Management. – LawrenceC Jul 13 '16 at 0:50
  • The problem is now half solved, I went to a store and they formatted the drive for me, literally took one minute, and now I can see the drive. The mystery remains why I couldn't see the drive so that I too, could format it. – GwenKillerby Jul 20 '16 at 18:08
2

I've seen similar behaviour from a drive that simply did not get the power it needed: Despite my USB port being advertised as USB 3.0, it turned out that it was incapable of actually supplying the 900mA that the standard dictates.

The workaround was to connect the harddrive via a USB hub that had an external power supply.


Other than that, there is the obvious: The possibility of a faulty drive. Ensure that it works as intended when connected via SATA directly.

2
  • This enclosure has its own power supply. and the drive is as good as new. I've no immediate possibility to test it in a desktop. – GwenKillerby Jul 13 '16 at 0:04
  • it wasn't the power, it was that it was unformatted. At least, after a computer shop guy formatted it, I could see the drive too on my computer. He said that it might be because the formatting mightve been odd. idk – GwenKillerby Jul 20 '16 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.