18

I just received a brand new work laptop and immediately installed the native version of Docker for Windows.

However I am seeing an issue that everytime the new network adapter for Docker via Hyper-V is enabled (vEthernet DockerNAT) then my Wifi Adapter is disabled and therefore I can not access the internet.

Whenever I try to enable the Wifi Adapter it keeps disabling itself immediately, the only way to get my internet back is by deactivating the DockerNAT HyperV Adapter.

This must surely work otherwise they wouldnt have released the Windows Native version publically?

Has anyone experienced this issue and know how to fix it? (This is my first experience with Hyper-V)

15
+100

As no one has answered yet, I will try to help, but warn that I do not use Docker and do not have your environment. This is all theory.

My theory is that the problem you are running into is with Windows 10 rather than with Docker or Hyper-V. I see a connection between the fact that on the one hand one cannot have both Ethernet and WiFi connections enabled at the same time, and on the other hand one cannot do NAT with WiFi. Therefore your enabling of NAT might cause the enabling of an Ethernet adapter which disables the wireless adapter.

If I am right, there might be two solutions to the problem :

  1. Connect the computer via wired wired rather than wireless
  2. Create a virtual Ethernet adapter around the wireless adapter:
    • Open Hyper-V manager
    • Click on the Virtual Network Manager and create an Internal Virtual Network by selecting Internal and clicking Add.
    • Give a meaningful Name
    • Apply and OK
    • Now a Virtual Network has been created which can be associated with 1 or more virtual machines.
    • On the host machine, in the Network and Sharing Center click on Change Adapter Settings
    • Select your WiFi Adapter and the Internal Virtual Network you created.
    • Right click and select Bridge Network and the bridge is created.
    • Use the Internal Virtual Network that you created initially for Docker NAT.

If the above does not work for some reason, a software that might be able to help is Connectify Hotspot (shareware/paid), which via its Virtual Router can share WiFi as Ethernet.

Another which might do the job is SoftEther VPN Open Source, which however requires connecting to a VPN in order to use its Virtual Network Adapter.

| improve this answer | |
  • 2
    You can do NAT (or any routing, really) with WiFi upstream no problem. It’s bridging that’s not possible. – Daniel B Aug 31 '16 at 12:05
  • What also worked for me, is to edit properties of the wifi adapter, to enable sharing via "vEthernet (DockerNAT)". Also had to disable the other adapter, "vEthernet (Default Switch)". – Jesse Jun 27 '18 at 15:44
  • Well, I cannot select "Bridge Connection" in right click menu. – Jerry Chong Aug 28 '19 at 8:49
8

After trying all types of remedies advised here and there, and with none of them fixing the issue, I eventually found that in my case it was 3rd party software (PulseSecure) that was disabling WiFi whenever Hyper-V adapter was active. So, if you have this software installed as well there is a good chance that it is causing the problem. You can disable "Pulse Secure Service" service to see if that's indeed the case, and if that solves your issue.

| improve this answer | |
  • 1
    I suffered from the same issue. Pulse version 5.3.4 (1555) with installer name ps-pulse-win-5.3R4.1HF11-b1555-64bitinstaller.msi seems to solve the issue. I can user Hyper-V and Docker and the wifi adapter stays enabled. – rodey Jul 12 '18 at 14:37
  • This is very interesting. Unfortunately, I use Pulse Secure for my company's VPN solution, so I don't know if this is something I can disable, as it would result in me not being able to connect at all to work. – Nick Klauer Aug 3 '18 at 19:13
  • If you are using PulseSecure for company VPN, this method cannot works. – Jerry Chong Aug 28 '19 at 9:01
1

Temporary Solution. Disable the vEthernet(DockerNAT) though this will last until your next reboot.

Goto Control Panel => Network and Sharing Center => Change Adapter Settings => Right click on vEthernet(DockerNAT) and Disable.

| improve this answer | |
0

Another temporary solution is just to configure the DockerNAT virtual switch to private though this will last until your next reboot.

Here is the source: https://forums.docker.com/t/wifi-adapter-disabled-when-hyper-v-network-adapter-enabled-native/18063/5

| improve this answer | |
0

I've found that by switching the docketNAT from internal to external solved the problem.

enter image description here

| improve this answer | |
  • Where are you setting this up? – WoJ May 11 '19 at 20:37
  • Ok, found it. It is the Hyper-V manager – WoJ May 11 '19 at 20:42
0

Run services.msc into command prompt

Check if the following services are running

  • Network Connections
  • Network List Service
  • Network Location Awareness
  • Network Store Interface Service
  • WLAN AutoConfig

If one of them is disabled, re-enable and try again

| improve this answer | |
0
  1. Open "Hyper-V Manager"
  2. Select your virtual machine
  3. Go to Action -> Virtual Switch Manager
  4. Select DockerNAT
  5. Select External Network and click OK
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.