1

Okay so, I'm trying to install Snow Leopard on a partition of a mid-2010 13" MacBook Pro that's otherwise running El Capitan completely fine (I'm typing this message using it right now). I need Snow Leopard in order to test some software for my company as well as to install some older Mac OS applications as well.

The thing is I've been running into a brick wall for the better part of the day trying to get this thing to work. I know by having looked at a comparison table that the original operating system that this computer came bundled with was actually Snow Leo (10.6.3 to be precise), and I should point out that I do NOT have the original install DVDs that came with the computer, I only have the retail SL disc at hand at the moment. The thing is, the DVD itself contains 10.6.4 which means that it should normally be fine (I would expect it not to work if the DVD that I was trying to install was an older version of 10.6 than the one originally installed on the system like 10.6.1).

Okay so, that being said, I'm running into a kernel panic each time I try to launch the installation. I put the DVD in the drive, restart the computer, hold down C, it works fine at first, the DVD boots, it shows me the old spinner like on 10.6 then after a couple of minutes it crashes miserably. I've read somewhere that this is because of an incompatibility between two different versions of Darwin and that the retail SL DVD is trying to run an older kernel version which would certainly explain it.

However I find it really hard to believe that on a computer which originally had 10.6 installed that you wouldn't at all be able to reinstall it properly... Anyone has any clues, even some workarounds ? I have no qualms about possibly having to wipe the hard drive again if necessary, since I only just reinstalled El Capitan on it, as the computer is just coming out of recovery mode limbo after an earlier botched attempt at an El Cap install, so there's nothing of note on the SSD at the moment.

Cheers, A.

  • Have you tried a PRAM reset? Search for "pram reset" from the menu bar at Help->Mac Help. The "Reset your computer's PRAM" section tells you how. Be sure to read the section "If you can't start up after resetting PRAM." – creidhne Jul 14 '16 at 3:38
  • Well now I have tried it, and ... doesn't work either. Same exact thing, even after the PRAM reset. :/ – Octaedre Jul 22 '16 at 16:44
  • Maybe the DVD is bad. I ran this on a Snow Leopard installation DVD: hdiutil create -format UDBZ -srcfolder /Volumes/Mac\ OS\ X\ Install\ DVD DVD.dmg in Terminal. – creidhne Jul 23 '16 at 0:02

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.