3

I'm having an issue since upgrading to Windows 10 regarding jump lists.

I have several programs pinned to the taskbar, one of which is Excel. Pinned to this jumplist are several Excel workbooks, mostly .xlsm files. Some of these files are network files stored on our server.

Inconsistently, when I try to open one of these network files, I am getting an error message "The item you selected is unavailable. It might have been moved, renamed or removed. Do you want to remove it from the list?" giving me the usual options of Cancel or Delete.

When I try again a few seconds later, the operation performs flawlessly and opens the relevant workbook.

I doubt it has anything to do with Excel. The jumplists were carried through as they are from Windows 7 during the upgrade. I haven't tried removing and reinstating the pinned links as they are obviously fine: they will open without any problem on the second attempt. The issue seems more to be related to the jumplist not connecting to the network quickly enough to find or open the network file.

I have done a careful Google search and have not been able to find any questions relating to this specific problem.

Update: I have now tried unpinning and re-pinning Excel to the taskbar. This had no effect on the problem.

However, the pinned items on the jumplist were remembered and re-appeared when I re-pinned Excel to the taskbar. So I have tried unpinning all these items and re-pinning them and so far have not been able to reproduce my issue (for about an hour).

Further Update: I can now confirm that the above has not resolved my issue, although it took a couple of days for the problem to re-surface. Still looking for help!

Update: I have now seen this issue reproduced on another computer here running Windows 10. No-one here has ever seen or reported this problem before when running Windows 7, so it appears to be a reproducable bug with Windows 10. If it makes any difference at all, which I struggle to believe, our server is actually a Linux server.

3
+100

I suspect the server might have cached the files incorrectly, leading to your request being denied initially because the file you asked for was different than the cached one in file location, but identical in metadata. If you clear the cache on the server by removing the file altogether, and reinstating a new version of it, you trash the broken cached file. Before you cleared the cache, you requested a file that was cached at a different location than the original file, leading to Windows misunderstanding the response as a 404 (File not found). When you make the request again, the most recent version of the file is cached, leading to your ability to access it. After saving on the NAS, your file is on the server, but not up-to-date with the cached version.

Tl;dr: Your computer asks for a file with different meta-data than the cached file. When you reset the cache, it should begin to store the file correctly.

Try backing up the files from your NAS. Afterwards, delete them from the NAS, open them on your local computer, and save them directly to the NAS from their respective programs (i.e. Excel). Unpin the Jumplist shortcuts, pin the new files, and you should be good. If all goes well, you're done. Else, try making shortcuts and pinning them.

| improve this answer | |
  • Thanks. Is this the answer? – var firstName Aug 25 '16 at 14:30
  • I don't know yet... please give me a little longer, and if it is I will mark it as such. Can you add a little more detail to your answer though, as we need to bear in mind future users with this question? We have discussed it in chat but they might not see that. – I-J Aug 25 '16 at 15:06
  • 1
    Good effort man!! – Pimp Juice IT Aug 25 '16 at 15:58
  • You've got it I think. Not only is it working now it has a snappy and responsive feel about it that I haven't seen for quite some time. Thanks very much indeed. – I-J Aug 26 '16 at 6:18
  • @ramhound do you award the bounty? – I-J Aug 26 '16 at 6:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.