2

Recently I was asked to deploy a scientific software packaged as a VirtualBox image (OVA format). I prepared the environment (Debian 7) - installed required packages, enabled DKMS, imported the image - however, when I tried to start the VM, I got the following message:

Error: failed to start machine. Error message: VT-x is not available (VERR_VMX_NO_VMX)

I did some reading and realized that the problem lies in the fact that my Debian environment is running as a Hyper-V VM (I have no control over that), which doesn't support hardware-enabled "stacked" virtualization. So, I decided to turn the VT-x mode off by using the following commands:

VBoxManage modifyvm <VM_NAME> –-hwvirtex off
VBoxManage modifyvm <VM_NAME> –-vtxvpid off

Unfortunately, for both commands, I'm getting the following error messages:

VBoxManage: error: Unknown option: -–hwvirtex
VBoxManage: error: Unknown option: -–vtxvpid

I have also tried to turn off hwvirtexclusive, but to no avail. Your advice will be much appreciated.

4
  • 1
    Is it perhaps a 64-bit guest OS? – Daniel B Jul 14 '16 at 11:29
  • @DanielB: Yes, Debian is 64-bit. Any workarounds for this case? – Aleksandr Blekh Jul 14 '16 at 11:30
  • 1
    No. Convert it to a Hyper-V VM (could work) or get a different appliance. – Daniel B Jul 14 '16 at 11:33
  • @DanielB: Thank you very much (+1). Unfortunately, it is impossible in this case, but I will think of an acceptable solution. – Aleksandr Blekh Jul 14 '16 at 11:39
3

I think you copied the two commands from a blog that automatically turned a "-" character (U+002D HYPHEN-MINUS) into a "–" character (U+2013 EN DASH).

You must use "-" rather than "–".

Here are the corrected commands:

VBoxManage modifyvm <VM_NAME> --hwvirtex off
VBoxManage modifyvm <VM_NAME> --vtxvpid off
6
  • Wow, great catch (+1 and accepted)! Thank you so much! However, even after running the fixed the commands (which were successful), an attempt to start VM fails with the same error message (1st message in my question). It seems that @Daniel B is correct in that the problem is that the outer guest VM is 64-bit. He just confirmed in the comment above. – Aleksandr Blekh Jul 14 '16 at 11:37
  • 1
    @AleksandrBlekh: Yeah, VirtualBox nested virtualization doesn't support 64-bit operating systems. Consider using QEMU, which does support emulating a 64-bit operating system without VT-x. This answer just addresses the fact that your "-" turned into a "–". – Deltik Jul 14 '16 at 11:42
  • Thank you for additional info and advice. Your answer perfectly addresses my question, hence upvote and accept. I appreciate your help. – Aleksandr Blekh Jul 14 '16 at 11:47
  • I have a couple of quick questions, if you don't mind. 1. Should I expect any problems from trying to run QEMU in a Hyper-V VM? 2. Is QEMU independent from KVM - why it's often mentioned as QEMU/KVM? 3. Is importing OVA image into QEMU ([wiki.hackzine.org/sysadmin/kvm-import-ova.html](like this)) losing some info about the target VM (requested RAM, etc.)? – Aleksandr Blekh Jul 14 '16 at 11:57
  • @AleksandrBlekh: Those questions should be asked in a separate post, as comments aren't for extended discussion and extra questions. If you make a new post, let me know and I'll be happy to write a proper answer. Otherwise, I encourage you to research QEMU and see what it is capable of. – Deltik Jul 14 '16 at 12:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.