4

I downloaded jre-8u91-windows-x64.tar.gz jdk-8u91-windows-x64.exe from Oracle web site

this Oracle web site. When I open it (by clicking double) installation windows open, then I click Next and there is a windows which shows the installation progress. But that is not processing. It is still 0 for nearly 20 minutes. My friends installed it in several minutes.

enter image description here

I have 64-bit Windows 10 OS. I have no idea about the reason.

5
  • One weirdness: You say the file is named jre -8u91-windows-x64.tar.gz, but the installation window in the picture says "Java Se Development Kit". The Development Kit installation file should be something with jdk in its name, not jre. Maybe you have got the wrong file?
    – Lii
    Jul 14, 2016 at 12:45
  • Actually I have jdk-8u91-windows-x64.exe in my Downloads folder. And I am trying to run that file. I think I gave you wrong link and name. Eclipse Java FX said that I need Java 8 and I downloaded jdk8 but as I said installation does not progress
    – Hilal
    Jul 14, 2016 at 12:56
  • 1
    I was able to install that specific version of the JDK 8 without a problem on my Windows 10 machine. Are you attempting to install it as a User or as an Administrator?
    – Ramhound
    Jul 14, 2016 at 14:27
  • 1
    I am installing as an Administrator. But now I tried to run as administrator and it fixed. Thanks
    – Hilal
    Jul 14, 2016 at 14:53
  • I had the same issue and it seems to have been related to having a java process open (I had gogland running), after closing that process the installer immediately completed.
    – John Jones
    Sep 27, 2017 at 20:36

3 Answers 3

3

In my case there's a Java process running (JDK 7). I just terminated that process and Java installer completed installation. In order to do it follow these steps.

  1. Open task manager.
  2. Find-out Java SE Binary process running.
  3. Right click on it and end task or use Alt + E
  4. Now Java installer completes installation.

Hope it'll be helpful.

0

I found that I thought I had this problem, and actually, there was a window that had popped up on another screen that required me to hit "next". If anyone else is having this issue I'd check to make sure that there isn't a popup behind one of your other windows.

0
-1

I found that my file had been "blocked" because it was downloaded.

  • Locate the file in your downloads folder.
  • Right-Click on Properties.
  • Press the 'UnBlock' button on the General tab.

Note: if your file was not blocked there will be no 'UnBlock' button.

I also ran as Administrator.

It still took forever to start (more than 10 minutes, so I went away and worked on something else).

Regarding Shashant's answer, the two JDK processes didn't seem to have any effect, but mine were jdk-8 and not jdk-7. They seemed to pop up as soon as I started the installer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.