2

First, I apologize in advance: I may not be know the correct terminology so I will explain the problem in detail. I have two PCs running Linux Mint and connected to the internet on a wired network. This network is usually restricted by a "captive portal". Box A connects to the internet freely without the captive portal, but Box B asks to login via a browser (captive portal).

As one of the employees, I shouldn't be restricted by the captive portal so I complained to the IT guy. There is some Cisco software that employees need to install so that they won't be restricted but it only runs for Windows and Mac, so I am told "You have to install Windows or use a Mac" and that is frustrating cos I know it can connect directly - at least the other box does so effortlessly. When I said so, the IT guy said I need to figure it out in that case since my use-case is an edge case, and nobody else is using Linux. I really need to use Linux, and I don't want to have to install Windows.

What I have tried: - I tested the network using Windows and a Mac, and they needed the captive portal to access the internet. Linux Box A simply does not. - I used the exact same cable in use by box A, for box B. Still no difference. - I noted the gateway and DNS on box A, and tried to put those details on box B. I realized they have the same DNS, but the gateway and subnet mask are different. After changing the gateway, still no luck. I also edited /etc/network/interfaces and added the gateway from box A, still no dice. I am probably missing something, but I don't know what it is.

Please any suggestions on what to do, are welcome.

1 Answer 1

2

First of all, your sysadmin is lazy. As I used to work with a lot of cisco gear, I find it hard to believe they released something only available for windows and mac.

It wouldn't suprise me if "Some Cisco software" is in fact their VPN client. While this VPN client was discontinued in 2012, it still remains popular to this day (it was the standard at my previous job).

However, if this is the case, then you're in luck: It can be done in linux. I cannot remember if the client I used was the one from cisco or not, but there are many alternatives that'll let you connect. openconnect is one alternative.

You may need to rewrite the .pcf file to use other clients. This didn't take me too much time, tho.


Alternatively, it may be a cache issue. I remember my laptop struggling for a while, as it loaded a CoovaChilli portal instead of a few websites I frequented, as it was cached once upon a time when I hadn't logged in via the portal yet. Clearing the cache resolved this.

3
  • Thanks! Any idea why one box doesn't need it and the other does?
    – Cogicero
    Jul 15, 2016 at 20:30
  • 1
    @Cogicero I Coincidentally updated my answer with info that may explain just that.
    – Jarmund
    Jul 15, 2016 at 20:31
  • Thanks... I have even reinstalled the Linux Mint on the PC (clean reinstall). Still no luck...
    – Cogicero
    Jul 16, 2016 at 1:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.