0

I wanted to use safe mode to get some things done on my PC. It worked in normal mode just fine, but no matter what I ever did, I could never get the advanced boot menu. F8 doesn't work, at at best I get my Asus BIOS screen.

So I went into msconfig, since that was the only possible way to start in safe mode. So I tell it to boot in safe mode, and restart. It starts up in safe mode, only to tell me that Windows failed to start installation. I restart it, and it does it again, and again, and again. So now I am stuck here. My computer which works in normal mode, has something wrong with safe mode, and now the only thing it will do is start in safe mode tell me windows will not install.

The internet tells me my only possible solution here is to completely reinstall windows or use a repair disk to basically do so. All because it wants to start in safe mode. Problem is (ofcourse) I don't have any repair disks or Windows 7 installation Disks, They were lost years ago.

So I should have the opposite problem of what everyone else has, Safe mode is the broken one. Is my only option really to somehow get a Windows 7 disk, or is there some other possible way to just override its settings to start in Safe mode?

0

Create a bootable UEFI Windows 7 bootable USB drive using Rufus and enter setup by pressing function key that selects boot devices usually f9 or f12. Select language and then on the next screen select Repair Pc. If this doesn't work, enter usb setup again and again select language. Now, on the screen with the repair option hold shift and press F10, this will bring up a cmd prompt box. Now try this...

Type bcdedit and take note of timeout value and truncatememory identifier If timeout value is set to 0 type bcdedit /timeout 30 press enter bcdedit press enter Check value is changed reboot if this doesn't work, repeat process to get to cmd prompt, only this time you'll need that identifier you made a note of. Type bcdedit /deletevalue {default} truncatememory

where "{default}" is the name of the identifier where "truncatememory" is listed by "bcdedit". Also set it to something else by typing:

bcdedit /set {default} truncatememory 0x100000000

Remember to always take a backup before you start: bcdedit /export c:\bcd_backup To restore it type: bcdedit /import c:\bcd_backup

and a help file can always be found when typing bcdedit /? or more specific help about an option: bcdedit /? e.g. bcdedit /? /set

Hope this helps

0

To do this without use of F8, boot Windows normally and click the Windows symbol at the bottom left of the screen and click on Run or hold windows key and press "R" on keyboard. Type msconfig to bring up the configuration box. Next click the Boot Tab and tick the Safe Boot box, with the option directly underneath set to minimal. Click OK and computer will ask if you want to restart now. Click yes, and yu should successfully boot up in safe mode.

N.B You will need to repeat this process and uncheck the safe bootbox to boot normally after you've done what you needed to in Safe Mode

2
  • Was i that unclear on what i said. I though i said i already did msconfig, selected safe mode, and when it boots, it trys to but fails, and because it fails, i cant gain access to msconfig again to undo it. – Ryan Jul 16 '16 at 2:36
  • Please read the question again carefully. Your answer does not answer the original question. OP is stuck already in safe mode (and it is broken). – DavidPostill Jul 16 '16 at 7:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.