37

Recently my Google Chrome on Windows 10 (only on a single machine out of 4) has had issues with connecting to websites for 2-5 minutes after the machine coming out of hibernate/sleep.

The issue is specific to chrome, as I can open IE and get to sites immediately. In addition, when working on local development through Visual Studio, Chrome can't even manage a localhost hosted page show up, until the issue has resolved itself after the 2-5 minutes.

Has anyone experienced this before, and know what kind of settings I should look at to diagnose and/or fix?

40

Not sure why this fixed it, but turning off "automatically detect settings" for LAN settings fixed it.

Settings:

enter image description here

Show advanced settings:

enter image description here

Change proxy settings:

enter image description here

LAN Settings:

enter image description here

Uncheck automatically detect settings:

enter image description here

  • 1
    Thank you, your solution works fine so far. Windows 10 (version 10.0.16299.19) and Chrome 62. – Alex Vang Nov 1 '17 at 15:06
  • 2
    I found a Chrome bug report about this a year ago without a fix. This fixed it, finally! I'm quite curious about how you found this. :) – Wouter Nov 28 '17 at 19:37
  • For reference, in case Chrome devs find this. My version is 62.0.3202.94 – Wouter Nov 28 '17 at 19:37
  • I don't really recall how I eventually figured it out... could have been something someone suggested, could have just been trial and error. Was too long ago for me to remember, but it seems it's been more of an issue for people lately as this question has gotten a few upvotes recently :O – Kritner Nov 28 '17 at 19:39
  • I'm not sure if this will fix it for me yet or not (I'll try to reply in a few days after testing). If this DOES work, I have a feeling it has something to do with the new Windows 10 Fall Creators Update (Version 1709). In Hyper-V, they added a new "Default Switch" that you cannot get rid of. It "hijacks" your network connection so that your VMs can communicate with your host OS. – DaleyKD Nov 28 '17 at 20:56
9

Sledgers answer is more relevant now after the Windows 10 Fall Creators edition, as addressed by daleykd in his initial response to the option to fixing in "Internet Options".

If using Hyper-V (even if not directly, i.e. for Docker), then Windows 10 creates a default switch network adaptor, that will route all traffic. This switch seems to fail on Chrome (and Firefox) for 30 to 60 seconds, and then reverts to the auto selected one (Wifi or Ethernet).

The simplest solution is to disable the interface:

netsh interface set interface "vEthernet (Default Switch)" admin=disable

Second Edit: This only actually occurs if Docker is using the new linux subsystem to create linux containers, and even if they are then the "Automatically detect settings" in "Internet Options" fixes it after a sleep. It was good to know the cause, though!

  • Won't that cause problems when actually using Hyper-V? I. e. inability for any virtual machine using that switch to access the network? – plocks Feb 8 '18 at 9:50
0

I disabled use of predictive service in chrome advanced settings and turned of automatic in Lan windows settings and it worked

-1

I had a similar problem which i discovered was due to virtual network adaptors, easy fix. I posted a 2 min video on youtube Showing the issue and the fix. hope this is of some help.

  • 2
    An answer should include the fix. Not solely a link somewhere else – G-. Apr 14 '18 at 7:15
  • +1 to counter the silly -1's. I'm glad you posted a helpful answer, even if it may just be a link. – chris Apr 16 '18 at 5:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.